why does Blue crash?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

why does Blue crash?

Menno Knevel
Hi

Blue 2.6.1 and Blue 2.7 dev is crashing on my main system Linux Mint 18 - not so on my secondary backup system 17.3. I hope you can make some sense out of this...

- i open 2.61 or 2.7
- i can run whatever project file and this works as expected, like in LM17.3
- after exactly running a project 2 times successfully ( and i have tried with different blue files), the playhead does not stop anymore and there is no sound from Csound.
Here is the inevitable screenshot: hangs.png
and here a screenshot that shows more or less the same:
no_stop.png

Both these screenshots are with 2.7dev, but the same goes for 2.6.1.

Because i have no problems in LM17.3,, do you happen to know how should i proceed in chasing this bug?

I also like to mention that i do all my testing of 2.7dev on the LM17.3.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: why does Blue crash?

Steven Yi
Hi Menno,

I think the first thing to check is what versions of things are you
using.  Could you tell me:

- version of Csound
- version of Java

If those end up the same, then I can try installing LM18 (which LM
desktop are you using? Cinnamon? Mate? Another?)

Thanks!
steven

On Sat, Dec 24, 2016 at 8:27 AM, Menno Knevel <[hidden email]> wrote:

> Hi
>
> Blue 2.6.1 and Blue 2.7 dev is crashing on my main system Linux Mint 18 -
> not so on my secondary backup system 17.3. I hope you can make some sense
> out of this...
>
> - i open 2.61 or 2.7
> - i can run whatever project file and this works as expected, like in LM17.3
> - after exactly running a project 2 times successfully ( and i have tried
> with different blue files), the playhead does not stop anymore and there is
> no sound from Csound.
> Here is the inevitable screenshot:  hangs.png
> <http://csound.1045644.n5.nabble.com/file/n5753565/hangs.png>
> and here a screenshot that shows more or less the same:
> no_stop.png <http://csound.1045644.n5.nabble.com/file/n5753565/no_stop.png>
>
> Both these screenshots are with 2.7dev, but the same goes for 2.6.1.
>
> Because i have no problems in LM17.3,, do you happen to know how should i
> proceed in chasing this bug?
>
> I also like to mention that i do all my testing of 2.7dev on the LM17.3.
>
>
>
>
> --
> View this message in context: http://csound.1045644.n5.nabble.com/why-does-Blue-crash-tp5753565.html
> Sent from the Csound - Blue - User mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Developer Access Program for Intel Xeon Phi Processors
> Access to Intel Xeon Phi processor-based developer platforms.
> With one year of Intel Parallel Studio XE.
> Training and support from Colfax.
> Order your platform today.http://sdm.link/intel
> _______________________________________________
> Bluemusic-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/bluemusic-users

------------------------------------------------------------------------------
Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today.http://sdm.link/intel
_______________________________________________
Bluemusic-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bluemusic-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: why does Blue crash?

Menno Knevel
I had the problems on LM18. Just to be sure i re-built Csound today to see if the problem was gone:
- --Csound version 6.09 (double samples) Dec 25 2016
- java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)

The system with a working Blue:
LM17.3
- Csound version 6.08 (double samples) Oct 11 2016
- java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)

but
i rebuilt Csound today and installed it on LM17.3.
Same error!
Luckily i made a backup of the old Csound version.

I think it has to do with Csound/Java? What has changed between 11 October and now in that area?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: why does Blue crash?

Steven Yi
Hi Menno,

I just tried Blue with latest from GIT in my Debian VM and am getting
a hang/crash after 2 successful runs as you described. I also checked
out the source to October 11th and it also runs correctly here.
There's certainly something happnening during csoundReset() within
Csound, but it could be many things that might cause this.  I suspect
it will take some time to diagnose.  I'll email the Csound-devel list
to let them know something is wrong.

Thanks!
steven

On Sun, Dec 25, 2016 at 11:06 AM, Menno Knevel <[hidden email]> wrote:

> I had the problems on LM18. Just to be sure i re-built Csound today to see if
> the problem was gone:
> - --Csound version 6.09 (double samples) Dec 25 2016
> - java version "1.8.0_111"
> Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
> Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)
>
> The system with a working Blue:
> LM17.3
> - Csound version 6.08 (double samples) Oct 11 2016
> - java version "1.8.0_111"
> Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
> Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)
>
> but
> i rebuilt Csound today and installed it on LM17.3.
> Same error!
> Luckily i made a backup of the old Csound version.
>
> I think it has to do with Csound/Java? What has changed between 11 October
> and now in that area?
>
>
>
> --
> View this message in context: http://csound.1045644.n5.nabble.com/why-does-Blue-crash-tp5753565p5753596.html
> Sent from the Csound - Blue - User mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Developer Access Program for Intel Xeon Phi Processors
> Access to Intel Xeon Phi processor-based developer platforms.
> With one year of Intel Parallel Studio XE.
> Training and support from Colfax.
> Order your platform today.http://sdm.link/intel
> _______________________________________________
> Bluemusic-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/bluemusic-users

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Bluemusic-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bluemusic-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: why does Blue crash?

Steven Yi
Hi Menno,

I fixed the problem in Csound.  It had to do with a double free of
memory in the signal flow graph opcodes.  You can update to the latest
from the develop branch for Csound and build and install.  The current
version should be fixed. Alternatively, something I tested which also
works, is to delete the signalflowgraph opcodes from the OPCODE6DIR64
folder.

Thanks!
steven


On Wed, Dec 28, 2016 at 7:26 PM, Steven Yi <[hidden email]> wrote:

> Hi Menno,
>
> I just tried Blue with latest from GIT in my Debian VM and am getting
> a hang/crash after 2 successful runs as you described. I also checked
> out the source to October 11th and it also runs correctly here.
> There's certainly something happnening during csoundReset() within
> Csound, but it could be many things that might cause this.  I suspect
> it will take some time to diagnose.  I'll email the Csound-devel list
> to let them know something is wrong.
>
> Thanks!
> steven
>
> On Sun, Dec 25, 2016 at 11:06 AM, Menno Knevel <[hidden email]> wrote:
>> I had the problems on LM18. Just to be sure i re-built Csound today to see if
>> the problem was gone:
>> - --Csound version 6.09 (double samples) Dec 25 2016
>> - java version "1.8.0_111"
>> Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
>> Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)
>>
>> The system with a working Blue:
>> LM17.3
>> - Csound version 6.08 (double samples) Oct 11 2016
>> - java version "1.8.0_111"
>> Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
>> Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)
>>
>> but
>> i rebuilt Csound today and installed it on LM17.3.
>> Same error!
>> Luckily i made a backup of the old Csound version.
>>
>> I think it has to do with Csound/Java? What has changed between 11 October
>> and now in that area?
>>
>>
>>
>> --
>> View this message in context: http://csound.1045644.n5.nabble.com/why-does-Blue-crash-tp5753565p5753596.html
>> Sent from the Csound - Blue - User mailing list archive at Nabble.com.
>>
>> ------------------------------------------------------------------------------
>> Developer Access Program for Intel Xeon Phi Processors
>> Access to Intel Xeon Phi processor-based developer platforms.
>> With one year of Intel Parallel Studio XE.
>> Training and support from Colfax.
>> Order your platform today.http://sdm.link/intel
>> _______________________________________________
>> Bluemusic-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/bluemusic-users

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Bluemusic-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/bluemusic-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: why does Blue crash?

Menno Knevel
..and now it works again...thanks, Steven!
Loading...