mytmpnam in Csound 5

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

mytmpnam in Csound 5

Michael Gogins
I implemented mytmpnam for all platforms, not just Windows, because the signatures were incompatible and the code apparently had not been tested on Windows. In other words, the checked-in code would not build on Windows.

It builds now, and I think it will build on Linux as well.

I am currently not able to test on Linux, but I will do so Monday or Tuesday. In the meantime, if there is a problem, you can look at one_file.c, main.c, and other places using tmpnam which now use mytmpnam.

There may be other problems with the recent code. The first time I rebuilt, the plugin opcodes did not build. Also, CsoundVST crashes when the user stops the performance, in ExitGraph. I am trying to debug this.

Regards,
Mike






-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7393&alloc_id=16281&op=click
_______________________________________________
Csound-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/csound-devel
Reply | Threaded
Open this post in threaded view
|

Re: mytmpnam in Csound 5

Michael Gogins
I rebuilt with current sources this morning, and the ExitGraph problem has vanished.

Looking good!

Regards,
Mike

-----Original Message-----
From: Michael Gogins <[hidden email]>
Sent: May 14, 2005 10:12 PM
To: [hidden email]
Subject: [Cs-dev] mytmpnam in Csound 5

I implemented mytmpnam for all platforms, not just Windows, because the signatures were incompatible and the code apparently had not been tested on Windows. In other words, the checked-in code would not build on Windows.

It builds now, and I think it will build on Linux as well.

I am currently not able to test on Linux, but I will do so Monday or Tuesday. In the meantime, if there is a problem, you can look at one_file.c, main.c, and other places using tmpnam which now use mytmpnam.

There may be other problems with the recent code. The first time I rebuilt, the plugin opcodes did not build. Also, CsoundVST crashes when the user stops the performance, in ExitGraph. I am trying to debug this.

Regards,
Mike






-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7393&alloc_id=16281&op=click
_______________________________________________
Csound-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/csound-devel





-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7393&alloc_id=16281&op=click
_______________________________________________
Csound-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/csound-devel
Reply | Threaded
Open this post in threaded view
|

Re: mytmpnam in Csound 5

Istvan Varga
Michael Gogins wrote:

> I rebuilt with current sources this morning,
 > and the ExitGraph problem has vanished.

There were still problems with dispset(), I have just committed some
fixes. Graphs seem to work now, although probably not in multiple
instances as static variables are still used in display code.


-------------------------------------------------------
This SF.Net email is sponsored by Oracle Space Sweepstakes
Want to be the first software developer in space?
Enter now for the Oracle Space Sweepstakes!
http://ads.osdn.com/?ad_id=7393&alloc_id=16281&op=click
_______________________________________________
Csound-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/csound-devel