Quantcast

Csound iOS - Switch to iOS 5 Dev Minimum Poll

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Csound iOS - Switch to iOS 5 Dev Minimum Poll

Steven Yi
Hi All,

I wanted to query the list to see if anyone who is working with the
Csound iOS SDK are currently working with older XCode/iOS SDK's that
do not support ARC, Storyboards, etc.  Trying to get a feel to see if
it'd be fine to update the SDK now or if there are community members
who would still like older dev tools supported.

Thanks!
steven


Send bugs reports to the Sourceforge bug tracker
            https://sourceforge.net/tracker/?group_id=81968&atid=564599
Discussions of bugs and features can be posted here
To unsubscribe, send email [hidden email] with body "unsubscribe csound"

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Csound iOS - Switch to iOS 5 Dev Minimum Poll

Steven Yi
Hi All,

To clarify, I was a bit mistaken about the issue.  Apparently:

===

* to submit to the app store, you do need to use the latest SDK to build the app

* however, you can build and target devices down to iOS 3

* if you use ARC, you can target down only to 4.3

* if you use storyboards, you have to target iOS 5 as a minimum

===

If we upgrade the Csound iOS SDK to use ARC and Storyboards, the result will be:

* The Csound iOS Examples project will only run on iOS 5

* The core csound-ios code/library will require a minimum iOS version of 4.3

====

So, the question should be: is anyone planning to build Csound-based
iOS apps that target iOS versions < 4.3 ?  I'll wait a day or two to
hear back anything, but will assume it will be fine to update.

Thanks,
steven



On Sun, Apr 8, 2012 at 1:23 AM, Steven Yi <[hidden email]> wrote:

> Hi All,
>
> I wanted to query the list to see if anyone who is working with the
> Csound iOS SDK are currently working with older XCode/iOS SDK's that
> do not support ARC, Storyboards, etc.  Trying to get a feel to see if
> it'd be fine to update the SDK now or if there are community members
> who would still like older dev tools supported.
>
> Thanks!
> steven


Send bugs reports to the Sourceforge bug tracker
            https://sourceforge.net/tracker/?group_id=81968&atid=564599
Discussions of bugs and features can be posted here
To unsubscribe, send email [hidden email] with body "unsubscribe csound"

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Csound iOS - Switch to iOS 5 Dev Minimum Poll

jclemz

I am working toward making something for 4.3+ so fine with me.  Thank you for asking and clarifying the situation, Steven.

John

On Apr 7, 2012 10:14 PM, "Steven Yi" <[hidden email]> wrote:
Hi All,

To clarify, I was a bit mistaken about the issue.  Apparently:

===

* to submit to the app store, you do need to use the latest SDK to build the app

* however, you can build and target devices down to iOS 3

* if you use ARC, you can target down only to 4.3

* if you use storyboards, you have to target iOS 5 as a minimum

===

If we upgrade the Csound iOS SDK to use ARC and Storyboards, the result will be:

* The Csound iOS Examples project will only run on iOS 5

* The core csound-ios code/library will require a minimum iOS version of 4.3

====

So, the question should be: is anyone planning to build Csound-based
iOS apps that target iOS versions < 4.3 ?  I'll wait a day or two to
hear back anything, but will assume it will be fine to update.

Thanks,
steven



On Sun, Apr 8, 2012 at 1:23 AM, Steven Yi <[hidden email]> wrote:
> Hi All,
>
> I wanted to query the list to see if anyone who is working with the
> Csound iOS SDK are currently working with older XCode/iOS SDK's that
> do not support ARC, Storyboards, etc.  Trying to get a feel to see if
> it'd be fine to update the SDK now or if there are community members
> who would still like older dev tools supported.
>
> Thanks!
> steven


Send bugs reports to the Sourceforge bug tracker
           https://sourceforge.net/tracker/?group_id=81968&atid=564599
Discussions of bugs and features can be posted here
To unsubscribe, send email [hidden email] with body "unsubscribe csound"

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Csound iOS - Switch to iOS 5 Dev Minimum Poll

Victor.Lazzarini
In reply to this post by Steven Yi

Steven,

it does appear like there is not a lot of choice. Setting it to 4.3+ looks reasonable to me.

Victor

Victor Lazzarini



Steven Yi <[hidden email]> wrote:


Hi All,

To clarify, I was a bit mistaken about the issue.  Apparently:

===

* to submit to the app store, you do need to use the latest SDK to build the app

* however, you can build and target devices down to iOS 3

* if you use ARC, you can target down only to 4.3

* if you use storyboards, you have to target iOS 5 as a minimum

===

If we upgrade the Csound iOS SDK to use ARC and Storyboards, the result will be:

* The Csound iOS Examples project will only run on iOS 5

* The core csound-ios code/library will require a minimum iOS version of 4.3

====

So, the question should be: is anyone planning to build Csound-based
iOS apps that target iOS versions < 4.3 ?  I'll wait a day or two to
hear back anything, but will assume it will be fine to update.

Thanks,
steven



On Sun, Apr 8, 2012 at 1:23 AM, Steven Yi <[hidden email]> wrote:

> Hi All,
>
> I wanted to query the list to see if anyone who is working with the
> Csound iOS SDK are currently working with older XCode/iOS SDK's that
> do not support ARC, Storyboards, etc.  Trying to get a feel to see if
> it'd be fine to update the SDK now or if there are community members
> who would still like older dev tools supported.
>
> Thanks!
> steven


Send bugs reports to the Sourceforge bug tracker
            https://sourceforge.net/tracker/?group_id=81968&atid=564599
Discussions of bugs and features can be posted here
To unsubscribe, send email [hidden email] with body "unsubscribe csound"

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Csound iOS - Switch to iOS 5 Dev Minimum Poll

Steven Yi
Hi John and Victor,

Thanks for your feedback! I tried to lookup iOS version statistics to
see percentage deployed per version.  The best link I found with
somewhat recent information was at:

http://david-smith.org/blog/2012/03/10/ios-5-dot-1-upgrade-stats/index.html

which seems to indicate about 19% of users having iOS 4.x (but doesn't
break down into 4.3, 4.2, etc.).

My guess is that most users using 4.x are on older devices (3g, 3gs)
because their devices aren't supported by iOS 5 or iOS 5 does not run
particularly well on it. Also, I think 4.3 was the earliest iOS that
came out on iPad.

Also to note, if someone wants to target earlier than 4.3, they do
have the option to not use CsoundObj and use CSOUND* directly as
that's all C.  They can also use the 5.17.3 release, which currently
works for < 4.3.

Anyways, just wanted to verify that these changes weren't going to
exclude anyone from using Csound for their iOS applications. Seems
reasonable to me from sorting through things yesterday and today to
move onto 4.3 minimum target and go ahead and use ARC and other newer
features within CsoundObj.

Thanks!
steven


On Sun, Apr 8, 2012 at 10:19 AM, Victor Lazzarini
<[hidden email]> wrote:

>
> Steven,
>
> it does appear like there is not a lot of choice. Setting it to 4.3+ looks
> reasonable to me.
>
> Victor
>
> Victor Lazzarini
>
>
>
> Steven Yi <[hidden email]> wrote:
>
>
> Hi All,
>
> To clarify, I was a bit mistaken about the issue.  Apparently:
>
> ===
>
> * to submit to the app store, you do need to use the latest SDK to build the
> app
>
> * however, you can build and target devices down to iOS 3
>
> * if you use ARC, you can target down only to 4.3
>
> * if you use storyboards, you have to target iOS 5 as a minimum
>
> ===
>
> If we upgrade the Csound iOS SDK to use ARC and Storyboards, the result will
> be:
>
> * The Csound iOS Examples project will only run on iOS 5
>
> * The core csound-ios code/library will require a minimum iOS version of 4.3
>
> ====
>
> So, the question should be: is anyone planning to build Csound-based
> iOS apps that target iOS versions < 4.3 ?  I'll wait a day or two to
> hear back anything, but will assume it will be fine to update.
>
> Thanks,
> steven
>
>
>
> On Sun, Apr 8, 2012 at 1:23 AM, Steven Yi <[hidden email]> wrote:
>> Hi All,
>>
>> I wanted to query the list to see if anyone who is working with the
>> Csound iOS SDK are currently working with older XCode/iOS SDK's that
>> do not support ARC, Storyboards, etc.  Trying to get a feel to see if
>> it'd be fine to update the SDK now or if there are community members
>> who would still like older dev tools supported.
>>
>> Thanks!
>> steven
>
>
> Send bugs reports to the Sourceforge bug tracker
>             https://sourceforge.net/tracker/?group_id=81968&atid=564599
> Discussions of bugs and features can be posted here
> To unsubscribe, send email [hidden email] with body "unsubscribe
> csound"
>


Send bugs reports to the Sourceforge bug tracker
            https://sourceforge.net/tracker/?group_id=81968&atid=564599
Discussions of bugs and features can be posted here
To unsubscribe, send email [hidden email] with body "unsubscribe csound"

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Csound iOS - Switch to iOS 5 Dev Minimum Poll

Matt Ingalls
switch to OS5
with SDK so new, i think you shouldn't support older OS/SDKs -- Apple's going to make whatever you do now obsolete in a year anyway so would be nice to start off the most forward-looking as you can! :)

looking forward to diving more into this!

On Apr 8, 2012, at 5:00 AM, Steven Yi wrote:

> Hi John and Victor,
>
> Thanks for your feedback! I tried to lookup iOS version statistics to
> see percentage deployed per version.  The best link I found with
> somewhat recent information was at:
>
> http://david-smith.org/blog/2012/03/10/ios-5-dot-1-upgrade-stats/index.html
>
> which seems to indicate about 19% of users having iOS 4.x (but doesn't
> break down into 4.3, 4.2, etc.).
>
> My guess is that most users using 4.x are on older devices (3g, 3gs)
> because their devices aren't supported by iOS 5 or iOS 5 does not run
> particularly well on it. Also, I think 4.3 was the earliest iOS that
> came out on iPad.
>
> Also to note, if someone wants to target earlier than 4.3, they do
> have the option to not use CsoundObj and use CSOUND* directly as
> that's all C.  They can also use the 5.17.3 release, which currently
> works for < 4.3.
>
> Anyways, just wanted to verify that these changes weren't going to
> exclude anyone from using Csound for their iOS applications. Seems
> reasonable to me from sorting through things yesterday and today to
> move onto 4.3 minimum target and go ahead and use ARC and other newer
> features within CsoundObj.
>
> Thanks!
> steven
>
>
> On Sun, Apr 8, 2012 at 10:19 AM, Victor Lazzarini
> <[hidden email]> wrote:
>>
>> Steven,
>>
>> it does appear like there is not a lot of choice. Setting it to 4.3+ looks
>> reasonable to me.
>>
>> Victor
>>
>> Victor Lazzarini
>>
>>
>>
>> Steven Yi <[hidden email]> wrote:
>>
>>
>> Hi All,
>>
>> To clarify, I was a bit mistaken about the issue.  Apparently:
>>
>> ===
>>
>> * to submit to the app store, you do need to use the latest SDK to build the
>> app
>>
>> * however, you can build and target devices down to iOS 3
>>
>> * if you use ARC, you can target down only to 4.3
>>
>> * if you use storyboards, you have to target iOS 5 as a minimum
>>
>> ===
>>
>> If we upgrade the Csound iOS SDK to use ARC and Storyboards, the result will
>> be:
>>
>> * The Csound iOS Examples project will only run on iOS 5
>>
>> * The core csound-ios code/library will require a minimum iOS version of 4.3
>>
>> ====
>>
>> So, the question should be: is anyone planning to build Csound-based
>> iOS apps that target iOS versions < 4.3 ?  I'll wait a day or two to
>> hear back anything, but will assume it will be fine to update.
>>
>> Thanks,
>> steven
>>
>>
>>
>> On Sun, Apr 8, 2012 at 1:23 AM, Steven Yi <[hidden email]> wrote:
>>> Hi All,
>>>
>>> I wanted to query the list to see if anyone who is working with the
>>> Csound iOS SDK are currently working with older XCode/iOS SDK's that
>>> do not support ARC, Storyboards, etc.  Trying to get a feel to see if
>>> it'd be fine to update the SDK now or if there are community members
>>> who would still like older dev tools supported.
>>>
>>> Thanks!
>>> steven
>>
>>
>> Send bugs reports to the Sourceforge bug tracker
>>             https://sourceforge.net/tracker/?group_id=81968&atid=564599
>> Discussions of bugs and features can be posted here
>> To unsubscribe, send email [hidden email] with body "unsubscribe
>> csound"
>>
>
>
> Send bugs reports to the Sourceforge bug tracker
>            https://sourceforge.net/tracker/?group_id=81968&atid=564599
> Discussions of bugs and features can be posted here
> To unsubscribe, send email [hidden email] with body "unsubscribe csound"
>



Send bugs reports to the Sourceforge bug tracker
            https://sourceforge.net/tracker/?group_id=81968&atid=564599
Discussions of bugs and features can be posted here
To unsubscribe, send email [hidden email] with body "unsubscribe csound"

Loading...