[Csnd] --realtime flag

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

[Csnd] --realtime flag

Rene-2
Hello,

Instruments using reinit opcode and --realtime flag seems to have a faulty behavior.
The reinit is done for the complete instrument regardless of the reinit label and rireturn locations.

(The included reinit.csd instrument prints Hello at every reinit)

I am on linux, csound 6.10.0

Is it normal?

Best,
René
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

reinit.csd (500 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] --realtime flag

Victor Lazzarini-2
It could be a bug.

Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy
Maynooth University
Ireland

On 2 Mar 2018, at 16:23, Rene <[hidden email]> wrote:

Hello,

Instruments using reinit opcode and --realtime flag seems to have a faulty behavior.
The reinit is done for the complete instrument regardless of the reinit label and rireturn locations.

(The included reinit.csd instrument prints Hello at every reinit)

I am on linux, csound 6.10.0

Is it normal?

Best,
René
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
<reinit.csd>
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] --realtime flag

Victor Lazzarini-2
Actually, can you try the latest (6.11)? This version has a completely overhauled realtime mode, and I remembered testing reinit and it worked.

Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy
Maynooth University
Ireland

On 2 Mar 2018, at 17:07, Victor Lazzarini <[hidden email]> wrote:

It could be a bug.

Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy
Maynooth University
Ireland

On 2 Mar 2018, at 16:23, Rene <[hidden email]> wrote:

Hello,

Instruments using reinit opcode and --realtime flag seems to have a faulty behavior.
The reinit is done for the complete instrument regardless of the reinit label and rireturn locations.

(The included reinit.csd instrument prints Hello at every reinit)

I am on linux, csound 6.10.0

Is it normal?

Best,
René
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
<reinit.csd>
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] --realtime flag

Rene-2
Hello,

Tanks for your answer.
 
I have tested from git (today download)

csound-master : give same bug as 6.10.0

csound-develop and csound-feature-realtime : (may be wrong version, i can't find 6.11)
For both i can't test because i got a continuous message

WARNING: instr 0 uses 3 p-fields but is given 0

then csound hang.


Best,
René








2018-03-02 18:48 GMT+01:00 Victor Lazzarini <[hidden email]>:
Actually, can you try the latest (6.11)? This version has a completely overhauled realtime mode, and I remembered testing reinit and it worked.

Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy
Maynooth University
Ireland

On 2 Mar 2018, at 17:07, Victor Lazzarini <[hidden email]> wrote:

It could be a bug.

Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy
Maynooth University
Ireland

On 2 Mar 2018, at 16:23, Rene <[hidden email]> wrote:

Hello,

Instruments using reinit opcode and --realtime flag seems to have a faulty behavior.
The reinit is done for the complete instrument regardless of the reinit label and rireturn locations.

(The included reinit.csd instrument prints Hello at every reinit)

I am on linux, csound 6.10.0

Is it normal?

Best,
René
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
<reinit.csd>
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] --realtime flag

Victor Lazzarini-2
The master branch is 6.10, old code. The develop branch is 6.11, e.g.

Csound version 6.11 beta (double samples) Mar  1 2018

Feature-realtime has been merged into develop, so that would have similar
code.

I tested your code and I am getting the WARNING, which I think it is a
bug in the latest checked in code. That problem is there with or without
—reatlime

Once that is fixed, you can test it again.
========================
Prof. Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy,
Maynooth University,
Maynooth, Co Kildare, Ireland
Tel: 00 353 7086936
Fax: 00 353 1 7086952

> On 2 Mar 2018, at 19:26, Rene <[hidden email]> wrote:
>
> Hello,
>
> Tanks for your answer.
>  
> I have tested from git (today download)
>
> csound-master : give same bug as 6.10.0
>
> csound-develop and csound-feature-realtime : (may be wrong version, i can't find 6.11)
> For both i can't test because i got a continuous message
>
> WARNING: instr 0 uses 3 p-fields but is given 0
>
> then csound hang.
>
>
> Best,
> René
>
>
>
>
>
>
>
>
> 2018-03-02 18:48 GMT+01:00 Victor Lazzarini <[hidden email]>:
> Actually, can you try the latest (6.11)? This version has a completely overhauled realtime mode, and I remembered testing reinit and it worked.
>
> Victor Lazzarini
> Dean of Arts, Celtic Studies, and Philosophy
> Maynooth University
> Ireland
>
> On 2 Mar 2018, at 17:07, Victor Lazzarini <[hidden email]> wrote:
>
>> It could be a bug.
>>
>> Victor Lazzarini
>> Dean of Arts, Celtic Studies, and Philosophy
>> Maynooth University
>> Ireland
>>
>> On 2 Mar 2018, at 16:23, Rene <[hidden email]> wrote:
>>
>>> Hello,
>>>
>>> Instruments using reinit opcode and --realtime flag seems to have a faulty behavior.
>>> The reinit is done for the complete instrument regardless of the reinit label and rireturn locations.
>>>
>>> (The included reinit.csd instrument prints Hello at every reinit)
>>>
>>> I am on linux, csound 6.10.0
>>>
>>> Is it normal?
>>>
>>> Best,
>>> René
>>> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
>>> <reinit.csd>
>> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
>
> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] --realtime flag

Victor Lazzarini-2
In reply to this post by Rene-2
actually, it’s a problem with realtime. I’ll fix it. I think it is to do with
timout, not reinit.
========================
Prof. Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy,
Maynooth University,
Maynooth, Co Kildare, Ireland
Tel: 00 353 7086936
Fax: 00 353 1 7086952

> On 2 Mar 2018, at 19:26, Rene <[hidden email]> wrote:
>
> Hello,
>
> Tanks for your answer.
>  
> I have tested from git (today download)
>
> csound-master : give same bug as 6.10.0
>
> csound-develop and csound-feature-realtime : (may be wrong version, i can't find 6.11)
> For both i can't test because i got a continuous message
>
> WARNING: instr 0 uses 3 p-fields but is given 0
>
> then csound hang.
>
>
> Best,
> René
>
>
>
>
>
>
>
>
> 2018-03-02 18:48 GMT+01:00 Victor Lazzarini <[hidden email]>:
> Actually, can you try the latest (6.11)? This version has a completely overhauled realtime mode, and I remembered testing reinit and it worked.
>
> Victor Lazzarini
> Dean of Arts, Celtic Studies, and Philosophy
> Maynooth University
> Ireland
>
> On 2 Mar 2018, at 17:07, Victor Lazzarini <[hidden email]> wrote:
>
>> It could be a bug.
>>
>> Victor Lazzarini
>> Dean of Arts, Celtic Studies, and Philosophy
>> Maynooth University
>> Ireland
>>
>> On 2 Mar 2018, at 16:23, Rene <[hidden email]> wrote:
>>
>>> Hello,
>>>
>>> Instruments using reinit opcode and --realtime flag seems to have a faulty behavior.
>>> The reinit is done for the complete instrument regardless of the reinit label and rireturn locations.
>>>
>>> (The included reinit.csd instrument prints Hello at every reinit)
>>>
>>> I am on linux, csound 6.10.0
>>>
>>> Is it normal?
>>>
>>> Best,
>>> René
>>> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
>>> <reinit.csd>
>> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
>
> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] --realtime flag

Victor Lazzarini-2
In reply to this post by Rene-2
I have fixed this now (in git develop), but there are a couple of caveats:

1) reinit should be avoided in --realtime mode: it stops performance to
run a reinit pass, and that is not a good idea. Even though it runs the
reinit on a separate thread, performance has to pause for reinitialisation.

2) opcodes like timeout would potentially have gaps in their time counting
due to the reinit pause.

In other words: although the instrument will work (with maybe some timout
time counting issues), it’s not a good realtime instrument.

========================
Prof. Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy,
Maynooth University,
Maynooth, Co Kildare, Ireland
Tel: 00 353 7086936
Fax: 00 353 1 7086952

> On 2 Mar 2018, at 19:26, Rene <[hidden email]> wrote:
>
> Hello,
>
> Tanks for your answer.
>  
> I have tested from git (today download)
>
> csound-master : give same bug as 6.10.0
>
> csound-develop and csound-feature-realtime : (may be wrong version, i can't find 6.11)
> For both i can't test because i got a continuous message
>
> WARNING: instr 0 uses 3 p-fields but is given 0
>
> then csound hang.
>
>
> Best,
> René
>
>
>
>
>
>
>
>
> 2018-03-02 18:48 GMT+01:00 Victor Lazzarini <[hidden email]>:
> Actually, can you try the latest (6.11)? This version has a completely overhauled realtime mode, and I remembered testing reinit and it worked.
>
> Victor Lazzarini
> Dean of Arts, Celtic Studies, and Philosophy
> Maynooth University
> Ireland
>
> On 2 Mar 2018, at 17:07, Victor Lazzarini <[hidden email]> wrote:
>
>> It could be a bug.
>>
>> Victor Lazzarini
>> Dean of Arts, Celtic Studies, and Philosophy
>> Maynooth University
>> Ireland
>>
>> On 2 Mar 2018, at 16:23, Rene <[hidden email]> wrote:
>>
>>> Hello,
>>>
>>> Instruments using reinit opcode and --realtime flag seems to have a faulty behavior.
>>> The reinit is done for the complete instrument regardless of the reinit label and rireturn locations.
>>>
>>> (The included reinit.csd instrument prints Hello at every reinit)
>>>
>>> I am on linux, csound 6.10.0
>>>
>>> Is it normal?
>>>
>>> Best,
>>> René
>>> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
>>> <reinit.csd>
>> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
>
> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] --realtime flag

Rene-2
Tested git develop, it is fine,

and thanks for the advise :)

Best,
René

2018-03-02 22:29 GMT+01:00 Victor Lazzarini <[hidden email]>:
I have fixed this now (in git develop), but there are a couple of caveats:

1) reinit should be avoided in --realtime mode: it stops performance to
run a reinit pass, and that is not a good idea. Even though it runs the
reinit on a separate thread, performance has to pause for reinitialisation.

2) opcodes like timeout would potentially have gaps in their time counting
due to the reinit pause.

In other words: although the instrument will work (with maybe some timout
time counting issues), it’s not a good realtime instrument.

========================
Prof. Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy,
Maynooth University,
Maynooth, Co Kildare, Ireland
Tel: 00 353 7086936
Fax: 00 353 1 7086952

> On 2 Mar 2018, at 19:26, Rene <[hidden email]> wrote:
>
> Hello,
>
> Tanks for your answer.
>
> I have tested from git (today download)
>
> csound-master : give same bug as 6.10.0
>
> csound-develop and csound-feature-realtime : (may be wrong version, i can't find 6.11)
> For both i can't test because i got a continuous message
>
> WARNING: instr 0 uses 3 p-fields but is given 0
>
> then csound hang.
>
>
> Best,
> René
>
>
>
>
>
>
>
>
> 2018-03-02 18:48 GMT+01:00 Victor Lazzarini <[hidden email]>:
> Actually, can you try the latest (6.11)? This version has a completely overhauled realtime mode, and I remembered testing reinit and it worked.
>
> Victor Lazzarini
> Dean of Arts, Celtic Studies, and Philosophy
> Maynooth University
> Ireland
>
> On 2 Mar 2018, at 17:07, Victor Lazzarini <[hidden email]> wrote:
>
>> It could be a bug.
>>
>> Victor Lazzarini
>> Dean of Arts, Celtic Studies, and Philosophy
>> Maynooth University
>> Ireland
>>
>> On 2 Mar 2018, at 16:23, Rene <[hidden email]> wrote:
>>
>>> Hello,
>>>
>>> Instruments using reinit opcode and --realtime flag seems to have a faulty behavior.
>>> The reinit is done for the complete instrument regardless of the reinit label and rireturn locations.
>>>
>>> (The included reinit.csd instrument prints Hello at every reinit)
>>>
>>> I am on linux, csound 6.10.0
>>>
>>> Is it normal?
>>>
>>> Best,
>>> René
>>> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
>>> <reinit.csd>
>> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
>
> Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here