[Csnd] ftsave does not work in Blue, but csd works

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Csnd] ftsave does not work in Blue, but csd works

zappfinger
I have a csd that saves recorded sound to a table.
After 10 seconds instr 2 saves the table to file. This does not work
when running in Blue, I get:

new alloc for instr 2:
INIT ERROR in instr 2: ftsave: unable to open file
     ftsave.S    "table1.ftsave"    0    1
       B 10.000 - note deleted.  i2 had 1 init errors

If i run the csd in Qt it works fine..

The csd is attached.


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

recsavetest.csd (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] ftsave does not work in Blue, but csd works

Steven Yi
Hi Richard,

I tried running the CSD from the commandline and it ran without
problems.  It looks like the CSD was generated itself from a .blue
project.  Could you post the .blue file?

steven

On Sun, Oct 8, 2017 at 6:55 AM, Richard <[hidden email]> wrote:

> I have a csd that saves recorded sound to a table.
> After 10 seconds instr 2 saves the table to file. This does not work when
> running in Blue, I get:
>
> new alloc for instr 2:
> INIT ERROR in instr 2: ftsave: unable to open file
>     ftsave.S    "table1.ftsave"    0    1
>       B 10.000 - note deleted.  i2 had 1 init errors
>
> If i run the csd in Qt it works fine..
>
> The csd is attached.
>
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>        https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] ftsave does not work in Blue, but csd works

zappfinger
Hi Steven,

Sure, here's the project.

Richard


On 11/10/17 00:40, Steven Yi wrote:

> Hi Richard,
>
> I tried running the CSD from the commandline and it ran without
> problems.  It looks like the CSD was generated itself from a .blue
> project.  Could you post the .blue file?
>
> steven
>
> On Sun, Oct 8, 2017 at 6:55 AM, Richard <[hidden email]> wrote:
>> I have a csd that saves recorded sound to a table.
>> After 10 seconds instr 2 saves the table to file. This does not work when
>> running in Blue, I get:
>>
>> new alloc for instr 2:
>> INIT ERROR in instr 2: ftsave: unable to open file
>>      ftsave.S    "table1.ftsave"    0    1
>>        B 10.000 - note deleted.  i2 had 1 init errors
>>
>> If i run the csd in Qt it works fine..
>>
>> The csd is attached.
>>
>>
>> Csound mailing list
>> [hidden email]
>> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>> Send bugs reports to
>>         https://github.com/csound/csound/issues
>> Discussions of bugs and features can be posted here
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>          https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

recplay.blue (18K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] ftsave does not work in Blue, but csd works

Steven Yi
I ran it here without problems:

PortAudio: selected output device 'Microsoft Sound Mapper - Output'
writing 512 sample blks of 64-bit floats to dac0
SECTION 1:
new alloc for instr 1:
ftable 1:
ftable 2:
new alloc for instr 3:
B  0.000 .. 10.000 T  9.999 TT  9.999 M:  0.00000  0.00000
new alloc for instr 2:
B 10.000 .. 11.000 T 11.000 TT 11.000 M:  0.00000  0.00000


My guess is that the original message is accurate and Csound was
indeed unable to open "table1.ftsave" for some reason?

I would check:

1. Was the .blue file saved to disk before you tested?  If not, it
might have tried to save/load the ftsave file into some temp directory
(though... that should generally be okay I think for permissions...)

2. Try using an absolute path to see if you get the same issue.

I'm running on Windows 10, with latest from Csound Git repo.

steven

On Wed, Oct 11, 2017 at 2:08 PM, Richard <[hidden email]> wrote:

> Hi Steven,
>
> Sure, here's the project.
>
> Richard
>
>
>
> On 11/10/17 00:40, Steven Yi wrote:
>>
>> Hi Richard,
>>
>> I tried running the CSD from the commandline and it ran without
>> problems.  It looks like the CSD was generated itself from a .blue
>> project.  Could you post the .blue file?
>>
>> steven
>>
>> On Sun, Oct 8, 2017 at 6:55 AM, Richard <[hidden email]> wrote:
>>>
>>> I have a csd that saves recorded sound to a table.
>>> After 10 seconds instr 2 saves the table to file. This does not work when
>>> running in Blue, I get:
>>>
>>> new alloc for instr 2:
>>> INIT ERROR in instr 2: ftsave: unable to open file
>>>      ftsave.S    "table1.ftsave"    0    1
>>>        B 10.000 - note deleted.  i2 had 1 init errors
>>>
>>> If i run the csd in Qt it works fine..
>>>
>>> The csd is attached.
>>>
>>>
>>> Csound mailing list
>>> [hidden email]
>>> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>>> Send bugs reports to
>>>         https://github.com/csound/csound/issues
>>> Discussions of bugs and features can be posted here
>>
>> Csound mailing list
>> [hidden email]
>> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>> Send bugs reports to
>>          https://github.com/csound/csound/issues
>> Discussions of bugs and features can be posted here
>
>
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>        https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here