[Csnd] exitnow bug?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[Csnd] exitnow bug?

Jim Aikin
Running the Floss Manual 01D03_linrand.csd in CsoundQt 0.95 in Windows 7
(Csound 6.10.0). This example is set up with an e statement with p1
99999, and a call in the orchestra to an instrument called "exit", which
uses the exitnow opcode.

The first run of this .csd is normal, but does not exit when "exit" is
called. I click the Stop button manually. Then I run the .csd again.
This time there is no text output to the console during playback. When
it finishes the second time, the Stop button does not work, and CsoundQt
crashes.

Commenting out the call to "exit" and setting the e statement manually
to 100 eliminates the crash and the failure to print to console. My
tentative conclusion is that exitnow has become wonky.

--Jim Aikin

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] exitnow bug?

jpff
Is this a Csound Qt issue?

⁣Sent from TypeApp ​

On Mar 7, 2018, 04:48, at 04:48, Jim Aikin <[hidden email]> wrote:

>Running the Floss Manual 01D03_linrand.csd in CsoundQt 0.95 in Windows
>7
>(Csound 6.10.0). This example is set up with an e statement with p1
>99999, and a call in the orchestra to an instrument called "exit",
>which
>uses the exitnow opcode.
>
>The first run of this .csd is normal, but does not exit when "exit" is
>called. I click the Stop button manually. Then I run the .csd again.
>This time there is no text output to the console during playback. When
>it finishes the second time, the Stop button does not work, and
>CsoundQt
>crashes.
>
>Commenting out the call to "exit" and setting the e statement manually
>to 100 eliminates the crash and the failure to print to console. My
>tentative conclusion is that exitnow has become wonky.
>
>--Jim Aikin
>
>Csound mailing list
>[hidden email]
>https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>Send bugs reports to
>        https://github.com/csound/csound/issues
>Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] exitnow bug?

Victor Lazzarini-2
 Not sure. We need to test the code.

Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy
Maynooth University
Ireland

> On 7 Mar 2018, at 14:11, John ff <[hidden email]> wrote:
>
> Is this a Csound Qt issue?
>
> ⁣Sent from TypeApp ​
>
>> On Mar 7, 2018, 04:48, at 04:48, Jim Aikin <[hidden email]> wrote:
>> Running the Floss Manual 01D03_linrand.csd in CsoundQt 0.95 in Windows
>> 7
>> (Csound 6.10.0). This example is set up with an e statement with p1
>> 99999, and a call in the orchestra to an instrument called "exit",
>> which
>> uses the exitnow opcode.
>>
>> The first run of this .csd is normal, but does not exit when "exit" is
>> called. I click the Stop button manually. Then I run the .csd again.
>> This time there is no text output to the console during playback. When
>> it finishes the second time, the Stop button does not work, and
>> CsoundQt
>> crashes.
>>
>> Commenting out the call to "exit" and setting the e statement manually
>> to 100 eliminates the crash and the failure to print to console. My
>> tentative conclusion is that exitnow has become wonky.
>>
>> --Jim Aikin
>>
>> Csound mailing list
>> [hidden email]
>> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>> Send bugs reports to
>>       https://github.com/csound/csound/issues
>> Discussions of bugs and features can be posted here
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>        https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] exitnow bug?

jpff
Just need to find the csd file

⁣Sent from TypeApp ​

On Mar 7, 2018, 14:23, at 14:23, Victor Lazzarini <[hidden email]> wrote:

> Not sure. We need to test the code.
>
>Victor Lazzarini
>Dean of Arts, Celtic Studies, and Philosophy
>Maynooth University
>Ireland
>
>> On 7 Mar 2018, at 14:11, John ff <[hidden email]> wrote:
>>
>> Is this a Csound Qt issue?
>>
>> ⁣Sent from TypeApp ​
>>
>>> On Mar 7, 2018, 04:48, at 04:48, Jim Aikin
><[hidden email]> wrote:
>>> Running the Floss Manual 01D03_linrand.csd in CsoundQt 0.95 in
>Windows
>>> 7
>>> (Csound 6.10.0). This example is set up with an e statement with p1
>>> 99999, and a call in the orchestra to an instrument called "exit",
>>> which
>>> uses the exitnow opcode.
>>>
>>> The first run of this .csd is normal, but does not exit when "exit"
>is
>>> called. I click the Stop button manually. Then I run the .csd again.
>
>>> This time there is no text output to the console during playback.
>When
>>> it finishes the second time, the Stop button does not work, and
>>> CsoundQt
>>> crashes.
>>>
>>> Commenting out the call to "exit" and setting the e statement
>manually
>>> to 100 eliminates the crash and the failure to print to console. My
>>> tentative conclusion is that exitnow has become wonky.
>>>
>>> --Jim Aikin
>>>
>>> Csound mailing list
>>> [hidden email]
>>> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>>> Send bugs reports to
>>>       https://github.com/csound/csound/issues
>>> Discussions of bugs and features can be posted here
>>
>> Csound mailing list
>> [hidden email]
>> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>> Send bugs reports to
>>        https://github.com/csound/csound/issues
>> Discussions of bugs and features can be posted here
>
>Csound mailing list
>[hidden email]
>https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>Send bugs reports to
>        https://github.com/csound/csound/issues
>Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] exitnow bug?

jpff
In reply to this post by Victor Lazzarini-2
Thanks to Victor I now have the csd file and it runs perfectly on the
command line, so I can not do anything to help, but looks like csoundqt's
problem.
==John ff


On Wed, 7 Mar 2018, Victor Lazzarini wrote:

> Not sure. We need to test the code.
>
> Victor Lazzarini
> Dean of Arts, Celtic Studies, and Philosophy
> Maynooth University
> Ireland
>
>> On 7 Mar 2018, at 14:11, John ff <[hidden email]> wrote:
>>
>> Is this a Csound Qt issue?
>>
>> ⁣Sent from TypeApp ​
>>
>>> On Mar 7, 2018, 04:48, at 04:48, Jim Aikin <[hidden email]> wrote:
>>> Running the Floss Manual 01D03_linrand.csd in CsoundQt 0.95 in Windows
>>> 7
>>> (Csound 6.10.0). This example is set up with an e statement with p1
>>> 99999, and a call in the orchestra to an instrument called "exit",
>>> which
>>> uses the exitnow opcode.
>>>
>>> The first run of this .csd is normal, but does not exit when "exit" is
>>> called. I click the Stop button manually. Then I run the .csd again.
>>> This time there is no text output to the console during playback. When
>>> it finishes the second time, the Stop button does not work, and
>>> CsoundQt
>>> crashes.
>>>
>>> Commenting out the call to "exit" and setting the e statement manually
>>> to 100 eliminates the crash and the failure to print to console. My
>>> tentative conclusion is that exitnow has become wonky.
>>>
>>> --Jim Aikin
>>>
>>> Csound mailing list
>>> [hidden email]
>>> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>>> Send bugs reports to
>>>       https://github.com/csound/csound/issues
>>> Discussions of bugs and features can be posted here
>>
>> Csound mailing list
>> [hidden email]
>> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>> Send bugs reports to
>>        https://github.com/csound/csound/issues
>> Discussions of bugs and features can be posted here
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>        https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here
>
Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] exitnow bug?

Tarmo Johannes-3
Thanks for info, I will check it out if I can reproduce with CsoundQt.
Greetings,
Tarmo

07.03.2018 17:06 kirjutas kuupäeval "jpff" <[hidden email]>:
Thanks to Victor I now have the csd file and it runs perfectly on the command line, so I can not do anything to help, but looks like csoundqt's problem.
==John ff


On Wed, 7 Mar 2018, Victor Lazzarini wrote:

Not sure. We need to test the code.

Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy
Maynooth University
Ireland

On 7 Mar 2018, at 14:11, John ff <[hidden email]> wrote:

Is this a Csound Qt issue?

⁣Sent from TypeApp ​

On Mar 7, 2018, 04:48, at 04:48, Jim Aikin <[hidden email]> wrote:
Running the Floss Manual 01D03_linrand.csd in CsoundQt 0.95 in Windows
7
(Csound 6.10.0). This example is set up with an e statement with p1
99999, and a call in the orchestra to an instrument called "exit",
which
uses the exitnow opcode.

The first run of this .csd is normal, but does not exit when "exit" is
called. I click the Stop button manually. Then I run the .csd again.
This time there is no text output to the console during playback. When
it finishes the second time, the Stop button does not work, and
CsoundQt
crashes.

Commenting out the call to "exit" and setting the e statement manually
to 100 eliminates the crash and the failure to print to console. My
tentative conclusion is that exitnow has become wonky.

--Jim Aikin

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
      https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] exitnow bug?

Tarmo Johannes-3
In reply to this post by Jim Aikin
Yes,

I can confirm, I can reproduce it in CsoundQt.
I will investigate (hopefully in coming days) what is the reason.

Thanks!

tarmo


On Wednesday, March 7, 2018 6:47:17 AM EET you wrote:

> Running the Floss Manual 01D03_linrand.csd in CsoundQt 0.95 in Windows 7
> (Csound 6.10.0). This example is set up with an e statement with p1
> 99999, and a call in the orchestra to an instrument called "exit", which
> uses the exitnow opcode.
>
> The first run of this .csd is normal, but does not exit when "exit" is
> called. I click the Stop button manually. Then I run the .csd again.
> This time there is no text output to the console during playback. When
> it finishes the second time, the Stop button does not work, and CsoundQt
> crashes.
>
> Commenting out the call to "exit" and setting the e statement manually
> to 100 eliminates the crash and the failure to print to console. My
> tentative conclusion is that exitnow has become wonky.
>
> --Jim Aikin
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>         https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here