[Csnd-dev] manual build

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Csnd-dev] manual build

Oeyvind Brandtsegg-3
I have some updates to the manual, but can not seem to get it built here.
make html
[ -d "" ] || (  \
echo "The XSL_BASE_PATH variable must be set to the XSL stylesheets installation directory" ; \
false )
The XSL_BASE_PATH variable must be set to the XSL stylesheets installation directory
make: *** [xsl/customXHTMLchunk.xsl] Error 1

I did 
sudo apt-get install -y docbook xsltproc

The readme says
'''
If DocBook is installed in a nonstandard way, you may see this error: “The XSL_BASE_PATH variable must be set to the XSL stylesheets installation directory.” To tell make where to find DocBook, run

make XSL_BASE_PATH=path/to/docbook/stylesheets ⟨target⟩
'''

I'm unsure what the path might be as I haven't set it explicitly, just installed docbook with apt-get

--
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd-dev] manual build

Francois PINOT
sudo apt-get install docbook-xsl, I think

Regards

François

2017-03-25 7:16 GMT+01:00 Oeyvind Brandtsegg <[hidden email]>:
I have some updates to the manual, but can not seem to get it built here.
make html
[ -d "" ] || (  \
echo "The XSL_BASE_PATH variable must be set to the XSL stylesheets installation directory" ; \
false )
The XSL_BASE_PATH variable must be set to the XSL stylesheets installation directory
make: *** [xsl/customXHTMLchunk.xsl] Error 1

I did 
sudo apt-get install -y docbook xsltproc

The readme says
'''
If DocBook is installed in a nonstandard way, you may see this error: “The XSL_BASE_PATH variable must be set to the XSL stylesheets installation directory.” To tell make where to find DocBook, run

make XSL_BASE_PATH=path/to/docbook/stylesheets ⟨target⟩
'''

I'm unsure what the path might be as I haven't set it explicitly, just installed docbook with apt-get

--

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd-dev] manual build

Oeyvind Brandtsegg-3
Thanks,
that got me one step further:

oyvind@oyvind-Precision-M6800:/media/oyvind/OSDisk/Source/manual$ make html
[ -d "/usr/share/xml/docbook/stylesheet/nwalsh/" ] || (  \
echo "The XSL_BASE_PATH variable must be set to the XSL stylesheets installation directory" ; \
false )
sed -e 's|@xsl_base_path@|/usr/share/xml/docbook/stylesheet/nwalsh/|' xsl/customXHTMLchunk.xsl.in > xsl/customXHTMLchunk.xsl
mkdir -p examples-xml
python csd2docbook.py
Traceback (most recent call last):
  File "csd2docbook.py", line 23, in <module>
    from pygments.lexers import CsoundDocumentLexer, CsoundOrchestraLexer, CsoundScoreLexer, _csound_builtins
ImportError: cannot import name CsoundDocumentLexer
make: *** [examples-xml/stamp] Error 1



2017-03-25 10:31 GMT+01:00 Francois PINOT <[hidden email]>:
sudo apt-get install docbook-xsl, I think

Regards

François

2017-03-25 7:16 GMT+01:00 Oeyvind Brandtsegg <[hidden email]>:
I have some updates to the manual, but can not seem to get it built here.
make html
[ -d "" ] || (  \
echo "The XSL_BASE_PATH variable must be set to the XSL stylesheets installation directory" ; \
false )
The XSL_BASE_PATH variable must be set to the XSL stylesheets installation directory
make: *** [xsl/customXHTMLchunk.xsl] Error 1

I did 
sudo apt-get install -y docbook xsltproc

The readme says
'''
If DocBook is installed in a nonstandard way, you may see this error: “The XSL_BASE_PATH variable must be set to the XSL stylesheets installation directory.” To tell make where to find DocBook, run

make XSL_BASE_PATH=path/to/docbook/stylesheets ⟨target⟩
'''

I'm unsure what the path might be as I haven't set it explicitly, just installed docbook with apt-get

--




--
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd-dev] manual build

Steven Yi
Perhaps this bit from the OSX directions in the README apply here:

To install Pygments, enter in Terminal `sudo easy_install pygments`.
If you have and older version of pygments installed, you might get an
error message that CsoundDocumentLexer was not found. If so, you can
updated your version of pygments using `easy_install —upgrade
pygments`.


On Sat, Mar 25, 2017 at 12:57 PM, Oeyvind Brandtsegg
<[hidden email]> wrote:

> Thanks,
> that got me one step further:
>
> oyvind@oyvind-Precision-M6800:/media/oyvind/OSDisk/Source/manual$ make html
> [ -d "/usr/share/xml/docbook/stylesheet/nwalsh/" ] || (  \
> echo "The XSL_BASE_PATH variable must be set to the XSL stylesheets
> installation directory" ; \
> false )
> sed -e 's|@xsl_base_path@|/usr/share/xml/docbook/stylesheet/nwalsh/|'
> xsl/customXHTMLchunk.xsl.in > xsl/customXHTMLchunk.xsl
> mkdir -p examples-xml
> python csd2docbook.py
> Traceback (most recent call last):
>   File "csd2docbook.py", line 23, in <module>
>     from pygments.lexers import CsoundDocumentLexer, CsoundOrchestraLexer,
> CsoundScoreLexer, _csound_builtins
> ImportError: cannot import name CsoundDocumentLexer
> make: *** [examples-xml/stamp] Error 1
>
>
>
> 2017-03-25 10:31 GMT+01:00 Francois PINOT <[hidden email]>:
>>
>> sudo apt-get install docbook-xsl, I think
>>
>> Regards
>>
>> François
>>
>> 2017-03-25 7:16 GMT+01:00 Oeyvind Brandtsegg <[hidden email]>:
>>>
>>> I have some updates to the manual, but can not seem to get it built here.
>>> make html
>>> [ -d "" ] || (  \
>>> echo "The XSL_BASE_PATH variable must be set to the XSL stylesheets
>>> installation directory" ; \
>>> false )
>>> The XSL_BASE_PATH variable must be set to the XSL stylesheets
>>> installation directory
>>> make: *** [xsl/customXHTMLchunk.xsl] Error 1
>>>
>>> I did
>>> sudo apt-get install -y docbook xsltproc
>>>
>>> The readme says
>>> '''
>>> If DocBook is installed in a nonstandard way, you may see this error:
>>> “The XSL_BASE_PATH variable must be set to the XSL stylesheets installation
>>> directory.” To tell make where to find DocBook, run
>>>
>>> make XSL_BASE_PATH=path/to/docbook/stylesheets ⟨target⟩
>>> '''
>>>
>>> I'm unsure what the path might be as I haven't set it explicitly, just
>>> installed docbook with apt-get
>>>
>>> --
>>> readme says
>>> Oeyvind Brandtsegg
>>> Professor of Music Technology
>>> NTNU
>>> 7491 Trondheim
>>> Norway
>>> Cell: +47 92 203 205
>>>
>>> http://www.partikkelaudio.com/
>>> http://crossadaptive.hf.ntnu.no
>>> http://gdsp.hf.ntnu.no/
>>> http://soundcloud.com/brandtsegg
>>> http://flyndresang.no/
>>> http://soundcloud.com/t-emp
>>>
>>
>>
>
>
>
> --
>
> Oeyvind Brandtsegg
> Professor of Music Technology
> NTNU
> 7491 Trondheim
> Norway
> Cell: +47 92 203 205
>
> http://www.partikkelaudio.com/
> http://crossadaptive.hf.ntnu.no
> http://gdsp.hf.ntnu.no/
> http://soundcloud.com/brandtsegg
> http://flyndresang.no/
> http://soundcloud.com/t-emp
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd-dev] manual build

Francois PINOT
pip install pygments should do it.

François

2017-03-25 18:14 GMT+01:00 Steven Yi <[hidden email]>:
Perhaps this bit from the OSX directions in the README apply here:

To install Pygments, enter in Terminal `sudo easy_install pygments`.
If you have and older version of pygments installed, you might get an
error message that CsoundDocumentLexer was not found. If so, you can
updated your version of pygments using `easy_install —upgrade
pygments`.


On Sat, Mar 25, 2017 at 12:57 PM, Oeyvind Brandtsegg
<[hidden email]> wrote:
> Thanks,
> that got me one step further:
>
> oyvind@oyvind-Precision-M6800:/media/oyvind/OSDisk/Source/manual$ make html
> [ -d "/usr/share/xml/docbook/stylesheet/nwalsh/" ] || (  \
> echo "The XSL_BASE_PATH variable must be set to the XSL stylesheets
> installation directory" ; \
> false )
> sed -e 's|@xsl_base_path@|/usr/share/xml/docbook/stylesheet/nwalsh/|'
> xsl/customXHTMLchunk.xsl.in > xsl/customXHTMLchunk.xsl
> mkdir -p examples-xml
> python csd2docbook.py
> Traceback (most recent call last):
>   File "csd2docbook.py", line 23, in <module>
>     from pygments.lexers import CsoundDocumentLexer, CsoundOrchestraLexer,
> CsoundScoreLexer, _csound_builtins
> ImportError: cannot import name CsoundDocumentLexer
> make: *** [examples-xml/stamp] Error 1
>
>
>
> 2017-03-25 10:31 GMT+01:00 Francois PINOT <[hidden email]>:
>>
>> sudo apt-get install docbook-xsl, I think
>>
>> Regards
>>
>> François
>>
>> 2017-03-25 7:16 GMT+01:00 Oeyvind Brandtsegg <[hidden email]>:
>>>
>>> I have some updates to the manual, but can not seem to get it built here.
>>> make html
>>> [ -d "" ] || (  \
>>> echo "The XSL_BASE_PATH variable must be set to the XSL stylesheets
>>> installation directory" ; \
>>> false )
>>> The XSL_BASE_PATH variable must be set to the XSL stylesheets
>>> installation directory
>>> make: *** [xsl/customXHTMLchunk.xsl] Error 1
>>>
>>> I did
>>> sudo apt-get install -y docbook xsltproc
>>>
>>> The readme says
>>> '''
>>> If DocBook is installed in a nonstandard way, you may see this error:
>>> “The XSL_BASE_PATH variable must be set to the XSL stylesheets installation
>>> directory.” To tell make where to find DocBook, run
>>>
>>> make XSL_BASE_PATH=path/to/docbook/stylesheets ⟨target⟩
>>> '''
>>>
>>> I'm unsure what the path might be as I haven't set it explicitly, just
>>> installed docbook with apt-get
>>>
>>> --
>>> readme says
>>> Oeyvind Brandtsegg
>>> Professor of Music Technology
>>> NTNU
>>> 7491 Trondheim
>>> Norway
>>> Cell: <a href="tel:%2B47%2092%20203%20205" value="+4792203205">+47 92 203 205
>>>
>>> http://www.partikkelaudio.com/
>>> http://crossadaptive.hf.ntnu.no
>>> http://gdsp.hf.ntnu.no/
>>> http://soundcloud.com/brandtsegg
>>> http://flyndresang.no/
>>> http://soundcloud.com/t-emp
>>>
>>
>>
>
>
>
> --
>
> Oeyvind Brandtsegg
> Professor of Music Technology
> NTNU
> 7491 Trondheim
> Norway
> Cell: <a href="tel:%2B47%2092%20203%20205" value="+4792203205">+47 92 203 205
>
> http://www.partikkelaudio.com/
> http://crossadaptive.hf.ntnu.no
> http://gdsp.hf.ntnu.no/
> http://soundcloud.com/brandtsegg
> http://flyndresang.no/
> http://soundcloud.com/t-emp
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd-dev] manual build

Oeyvind Brandtsegg-3
In reply to this post by Steven Yi
That was it. Thank you Steven.

Should the same message be written in the Linux directions?
I had pygments, but needed to upgrade:
sudo pip install pygments --upgrade



2017-03-25 10:14 GMT-07:00 Steven Yi <[hidden email]>:
Perhaps this bit from the OSX directions in the README apply here:

To install Pygments, enter in Terminal `sudo easy_install pygments`.
If you have and older version of pygments installed, you might get an
error message that CsoundDocumentLexer was not found. If so, you can
updated your version of pygments using `easy_install —upgrade
pygments`.


On Sat, Mar 25, 2017 at 12:57 PM, Oeyvind Brandtsegg
<[hidden email]> wrote:
> Thanks,
> that got me one step further:
>
> oyvind@oyvind-Precision-M6800:/media/oyvind/OSDisk/Source/manual$ make html
> [ -d "/usr/share/xml/docbook/stylesheet/nwalsh/" ] || (  \
> echo "The XSL_BASE_PATH variable must be set to the XSL stylesheets
> installation directory" ; \
> false )
> sed -e 's|@xsl_base_path@|/usr/share/xml/docbook/stylesheet/nwalsh/|'
> xsl/customXHTMLchunk.xsl.in > xsl/customXHTMLchunk.xsl
> mkdir -p examples-xml
> python csd2docbook.py
> Traceback (most recent call last):
>   File "csd2docbook.py", line 23, in <module>
>     from pygments.lexers import CsoundDocumentLexer, CsoundOrchestraLexer,
> CsoundScoreLexer, _csound_builtins
> ImportError: cannot import name CsoundDocumentLexer
> make: *** [examples-xml/stamp] Error 1
>
>
>
> 2017-03-25 10:31 GMT+01:00 Francois PINOT <[hidden email]>:
>>
>> sudo apt-get install docbook-xsl, I think
>>
>> Regards
>>
>> François
>>
>> 2017-03-25 7:16 GMT+01:00 Oeyvind Brandtsegg <[hidden email]>:
>>>
>>> I have some updates to the manual, but can not seem to get it built here.
>>> make html
>>> [ -d "" ] || (  \
>>> echo "The XSL_BASE_PATH variable must be set to the XSL stylesheets
>>> installation directory" ; \
>>> false )
>>> The XSL_BASE_PATH variable must be set to the XSL stylesheets
>>> installation directory
>>> make: *** [xsl/customXHTMLchunk.xsl] Error 1
>>>
>>> I did
>>> sudo apt-get install -y docbook xsltproc
>>>
>>> The readme says
>>> '''
>>> If DocBook is installed in a nonstandard way, you may see this error:
>>> “The XSL_BASE_PATH variable must be set to the XSL stylesheets installation
>>> directory.” To tell make where to find DocBook, run
>>>
>>> make XSL_BASE_PATH=path/to/docbook/stylesheets ⟨target⟩
>>> '''
>>>
>>> I'm unsure what the path might be as I haven't set it explicitly, just
>>> installed docbook with apt-get
>>>
>>> --
>>> readme says
>>> Oeyvind Brandtsegg
>>> Professor of Music Technology
>>> NTNU
>>> 7491 Trondheim
>>> Norway
>>> Cell: <a href="tel:%2B47%2092%20203%20205" value="+4792203205">+47 92 203 205
>>>
>>> http://www.partikkelaudio.com/
>>> http://crossadaptive.hf.ntnu.no
>>> http://gdsp.hf.ntnu.no/
>>> http://soundcloud.com/brandtsegg
>>> http://flyndresang.no/
>>> http://soundcloud.com/t-emp
>>>
>>
>>
>
>
>
> --
>
> Oeyvind Brandtsegg
> Professor of Music Technology
> NTNU
> 7491 Trondheim
> Norway
> Cell: <a href="tel:%2B47%2092%20203%20205" value="+4792203205">+47 92 203 205
>
> http://www.partikkelaudio.com/
> http://crossadaptive.hf.ntnu.no
> http://gdsp.hf.ntnu.no/
> http://soundcloud.com/brandtsegg
> http://flyndresang.no/
> http://soundcloud.com/t-emp
>



--
Loading...