[Csnd-dev] csound-extended

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Csnd-dev] csound-extended

Michael Gogins-2
As you know a number of components previously maintained in the Csound
repository at https://github.com/csound/csound have been moved to
external repositories.

My share of these components may now be found in a new Github
repository maintained by me at
https://github.com/gogins/csound-extended. For more information on its
contents, view the README.md there.

At this time, I have released a beta version of the programs and
libraries in csound-extended (including a build of Csound itself which
is synchronized with the Csound repository) for Ubuntu 17.10, as well
as an updated, signed version of the Csound for Android app (also
published to the Google Play Store). This is a pre-release version and
should only be installed locally (i.e., in your home directory or in
/usr/local).

Building from source _should_ be simple: clone the repository and run
the build script.

Please send any bug reports, comments, or suggestions to me.

Regards,
Mike

-----------------------------------------------------
Michael Gogins
Irreducible Productions
http://michaelgogins.tumblr.com
Michael dot Gogins at gmail dot com
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd-dev] csound-extended

Dave Seidel
Thanks, Mike.

On Thu, Feb 1, 2018 at 4:16 PM, Michael Gogins <[hidden email]> wrote:
As you know a number of components previously maintained in the Csound
repository at https://github.com/csound/csound have been moved to
external repositories.

My share of these components may now be found in a new Github
repository maintained by me at
https://github.com/gogins/csound-extended. For more information on its
contents, view the README.md there.

At this time, I have released a beta version of the programs and
libraries in csound-extended (including a build of Csound itself which
is synchronized with the Csound repository) for Ubuntu 17.10, as well
as an updated, signed version of the Csound for Android app (also
published to the Google Play Store). This is a pre-release version and
should only be installed locally (i.e., in your home directory or in
/usr/local).

Building from source _should_ be simple: clone the repository and run
the build script.

Please send any bug reports, comments, or suggestions to me.

Regards,
Mike

-----------------------------------------------------
Michael Gogins
Irreducible Productions
http://michaelgogins.tumblr.com
Michael dot Gogins at gmail dot com



--
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd-dev] csound-extended

Dave Seidel
Mike, I just gave it a try and have some notes.

update-dependencies.sh:
I had to install the p7zip-full package (I'm on Linux Mint) to get the 7z command that's used in the script. Once I did that, I was able to run the scrip to completion. Might be good to document that sudo is used, so most pople will be prompted for a password.

build-linux.sh:
This failed with the following output, implying I think that there are additional dependencies that I'm missing:

CMake Error at /usr/share/llvm-3.8/cmake/LLVMConfig.cmake:178 (include):
  include could not find load file:

    /usr/share/llvm/cmake/LLVMExports.cmake
Call Stack (most recent call first):
  CMakeLists.txt:103 (find_package)


CMake Error at /usr/share/llvm-3.8/cmake/LLVMConfig.cmake:181 (include):
  include could not find load file:

    /usr/share/llvm/cmake/LLVM-Config.cmake
Call Stack (most recent call first):
  CMakeLists.txt:103 (find_package)


-- Could NOT find PORTSMF (missing:  PORTSMF_INCLUDE_DIR) 
-- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8") 
-- Found PNG: /usr/lib/x86_64-linux-gnu/libpng.so (found version "1.2.54") 
-- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython2.7.so (found suitable version "2.7.12", minimum required is "2.7") 
CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Qt5/Qt5Config.cmake:26 (find_package):
  Could not find a package configuration file provided by "Qt5WebEngine" with
  any of the following names:

    Qt5WebEngineConfig.cmake
    qt5webengine-config.cmake

  Add the installation prefix of "Qt5WebEngine" to CMAKE_PREFIX_PATH or set
  "Qt5WebEngine_DIR" to a directory containing one of the above files.  If
  "Qt5WebEngine" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  CMakeLists.txt:112 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/dave/src/csound-extended/build-linux/CMakeFiles/CMakeOutput.log".
make: *** No targets specified and no makefile found.  Stop.
Installing...
make: *** No rule to make target 'install'.  Stop.
Building packages...
make: *** No rule to make target 'package'.  Stop.
Debian package contents:
Running lintian...
warning: cannot find binary, udeb or source package build-linux/csound-extended-6.11.0-beta-Linux.deb in lab (skipping)
Finished building all for Linux.



On Thu, Feb 1, 2018 at 4:42 PM, Dave Seidel <[hidden email]> wrote:
Thanks, Mike.

On Thu, Feb 1, 2018 at 4:16 PM, Michael Gogins <[hidden email]> wrote:
As you know a number of components previously maintained in the Csound
repository at https://github.com/csound/csound have been moved to
external repositories.

My share of these components may now be found in a new Github
repository maintained by me at
https://github.com/gogins/csound-extended. For more information on its
contents, view the README.md there.

At this time, I have released a beta version of the programs and
libraries in csound-extended (including a build of Csound itself which
is synchronized with the Csound repository) for Ubuntu 17.10, as well
as an updated, signed version of the Csound for Android app (also
published to the Google Play Store). This is a pre-release version and
should only be installed locally (i.e., in your home directory or in
/usr/local).

Building from source _should_ be simple: clone the repository and run
the build script.

Please send any bug reports, comments, or suggestions to me.

Regards,
Mike

-----------------------------------------------------
Michael Gogins
Irreducible Productions
http://michaelgogins.tumblr.com
Michael dot Gogins at gmail dot com



--



--
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd-dev] csound-extended

Dave Seidel
Sorry, I do think the llvm error is on my end -- I think cmake expects to find files in /usr/share/llvm/... -- I have /usr/share/llvm-3.8 and /usr/share/llvm-5.0. Probably I need to add a link.

On Thu, Feb 1, 2018 at 5:22 PM, Dave Seidel <[hidden email]> wrote:
Mike, I just gave it a try and have some notes.

update-dependencies.sh:
I had to install the p7zip-full package (I'm on Linux Mint) to get the 7z command that's used in the script. Once I did that, I was able to run the scrip to completion. Might be good to document that sudo is used, so most pople will be prompted for a password.

build-linux.sh:
This failed with the following output, implying I think that there are additional dependencies that I'm missing:

CMake Error at /usr/share/llvm-3.8/cmake/LLVMConfig.cmake:178 (include):
  include could not find load file:

    /usr/share/llvm/cmake/LLVMExports.cmake
Call Stack (most recent call first):
  CMakeLists.txt:103 (find_package)


CMake Error at /usr/share/llvm-3.8/cmake/LLVMConfig.cmake:181 (include):
  include could not find load file:

    /usr/share/llvm/cmake/LLVM-Config.cmake
Call Stack (most recent call first):
  CMakeLists.txt:103 (find_package)


-- Could NOT find PORTSMF (missing:  PORTSMF_INCLUDE_DIR) 
-- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8") 
-- Found PNG: /usr/lib/x86_64-linux-gnu/libpng.so (found version "1.2.54") 
-- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython2.7.so (found suitable version "2.7.12", minimum required is "2.7") 
CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Qt5/Qt5Config.cmake:26 (find_package):
  Could not find a package configuration file provided by "Qt5WebEngine" with
  any of the following names:

    Qt5WebEngineConfig.cmake
    qt5webengine-config.cmake

  Add the installation prefix of "Qt5WebEngine" to CMAKE_PREFIX_PATH or set
  "Qt5WebEngine_DIR" to a directory containing one of the above files.  If
  "Qt5WebEngine" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  CMakeLists.txt:112 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/dave/src/csound-extended/build-linux/CMakeFiles/CMakeOutput.log".
make: *** No targets specified and no makefile found.  Stop.
Installing...
make: *** No rule to make target 'install'.  Stop.
Building packages...
make: *** No rule to make target 'package'.  Stop.
Debian package contents:
Running lintian...
warning: cannot find binary, udeb or source package build-linux/csound-extended-6.11.0-beta-Linux.deb in lab (skipping)
Finished building all for Linux.



On Thu, Feb 1, 2018 at 4:42 PM, Dave Seidel <[hidden email]> wrote:
Thanks, Mike.

On Thu, Feb 1, 2018 at 4:16 PM, Michael Gogins <[hidden email]> wrote:
As you know a number of components previously maintained in the Csound
repository at https://github.com/csound/csound have been moved to
external repositories.

My share of these components may now be found in a new Github
repository maintained by me at
https://github.com/gogins/csound-extended. For more information on its
contents, view the README.md there.

At this time, I have released a beta version of the programs and
libraries in csound-extended (including a build of Csound itself which
is synchronized with the Csound repository) for Ubuntu 17.10, as well
as an updated, signed version of the Csound for Android app (also
published to the Google Play Store). This is a pre-release version and
should only be installed locally (i.e., in your home directory or in
/usr/local).

Building from source _should_ be simple: clone the repository and run
the build script.

Please send any bug reports, comments, or suggestions to me.

Regards,
Mike

-----------------------------------------------------
Michael Gogins
Irreducible Productions
http://michaelgogins.tumblr.com
Michael dot Gogins at gmail dot com



--



--



--
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd-dev] csound-extended

Michael Gogins-2
Thanks for the info. You need to be on Ubuntu 17.10 to find the
required Qt packages, are you? There probably is another way to get it
to work if you are on another version.

Best,
Mike

-----------------------------------------------------
Michael Gogins
Irreducible Productions
http://michaelgogins.tumblr.com
Michael dot Gogins at gmail dot com


On Thu, Feb 1, 2018 at 6:24 PM, Dave Seidel <[hidden email]> wrote:

> Sorry, I do think the llvm error is on my end -- I think cmake expects to
> find files in /usr/share/llvm/... -- I have /usr/share/llvm-3.8 and
> /usr/share/llvm-5.0. Probably I need to add a link.
>
> On Thu, Feb 1, 2018 at 5:22 PM, Dave Seidel <[hidden email]> wrote:
>>
>> Mike, I just gave it a try and have some notes.
>>
>> update-dependencies.sh:
>> I had to install the p7zip-full package (I'm on Linux Mint) to get the 7z
>> command that's used in the script. Once I did that, I was able to run the
>> scrip to completion. Might be good to document that sudo is used, so most
>> pople will be prompted for a password.
>>
>> build-linux.sh:
>> This failed with the following output, implying I think that there are
>> additional dependencies that I'm missing:
>>
>> CMake Error at /usr/share/llvm-3.8/cmake/LLVMConfig.cmake:178 (include):
>>   include could not find load file:
>>
>>     /usr/share/llvm/cmake/LLVMExports.cmake
>> Call Stack (most recent call first):
>>   CMakeLists.txt:103 (find_package)
>>
>>
>> CMake Error at /usr/share/llvm-3.8/cmake/LLVMConfig.cmake:181 (include):
>>   include could not find load file:
>>
>>     /usr/share/llvm/cmake/LLVM-Config.cmake
>> Call Stack (most recent call first):
>>   CMakeLists.txt:103 (find_package)
>>
>>
>> -- Could NOT find PORTSMF (missing:  PORTSMF_INCLUDE_DIR)
>> -- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8")
>> -- Found PNG: /usr/lib/x86_64-linux-gnu/libpng.so (found version "1.2.54")
>> -- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython2.7.so (found
>> suitable version "2.7.12", minimum required is "2.7")
>> CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Qt5/Qt5Config.cmake:26
>> (find_package):
>>   Could not find a package configuration file provided by "Qt5WebEngine"
>> with
>>   any of the following names:
>>
>>     Qt5WebEngineConfig.cmake
>>     qt5webengine-config.cmake
>>
>>   Add the installation prefix of "Qt5WebEngine" to CMAKE_PREFIX_PATH or
>> set
>>   "Qt5WebEngine_DIR" to a directory containing one of the above files.  If
>>   "Qt5WebEngine" provides a separate development package or SDK, be sure
>> it
>>   has been installed.
>> Call Stack (most recent call first):
>>   CMakeLists.txt:112 (find_package)
>>
>>
>> -- Configuring incomplete, errors occurred!
>> See also
>> "/home/dave/src/csound-extended/build-linux/CMakeFiles/CMakeOutput.log".
>> make: *** No targets specified and no makefile found.  Stop.
>> Installing...
>> make: *** No rule to make target 'install'.  Stop.
>> Building packages...
>> make: *** No rule to make target 'package'.  Stop.
>> Debian package contents:
>> Running lintian...
>> warning: cannot find binary, udeb or source package
>> build-linux/csound-extended-6.11.0-beta-Linux.deb in lab (skipping)
>> Finished building all for Linux.
>>
>>
>>
>> On Thu, Feb 1, 2018 at 4:42 PM, Dave Seidel <[hidden email]> wrote:
>>>
>>> Thanks, Mike.
>>>
>>> On Thu, Feb 1, 2018 at 4:16 PM, Michael Gogins <[hidden email]>
>>> wrote:
>>>>
>>>> As you know a number of components previously maintained in the Csound
>>>> repository at https://github.com/csound/csound have been moved to
>>>> external repositories.
>>>>
>>>> My share of these components may now be found in a new Github
>>>> repository maintained by me at
>>>> https://github.com/gogins/csound-extended. For more information on its
>>>> contents, view the README.md there.
>>>>
>>>> At this time, I have released a beta version of the programs and
>>>> libraries in csound-extended (including a build of Csound itself which
>>>> is synchronized with the Csound repository) for Ubuntu 17.10, as well
>>>> as an updated, signed version of the Csound for Android app (also
>>>> published to the Google Play Store). This is a pre-release version and
>>>> should only be installed locally (i.e., in your home directory or in
>>>> /usr/local).
>>>>
>>>> Building from source _should_ be simple: clone the repository and run
>>>> the build script.
>>>>
>>>> Please send any bug reports, comments, or suggestions to me.
>>>>
>>>> Regards,
>>>> Mike
>>>>
>>>> -----------------------------------------------------
>>>> Michael Gogins
>>>> Irreducible Productions
>>>> http://michaelgogins.tumblr.com
>>>> Michael dot Gogins at gmail dot com
>>>
>>>
>>>
>>>
>>> --
>>> http://mysterybear.net
>>> https://soundcloud.com/mysterybear
>>> https://mysterybear.bandcamp.com
>>>
>>> http://recordings.irritablehedgehog.com/album/dave-seidel-60-hz
>>
>>
>>
>>
>> --
>> http://mysterybear.net
>> https://soundcloud.com/mysterybear
>> https://mysterybear.bandcamp.com
>>
>> http://recordings.irritablehedgehog.com/album/dave-seidel-60-hz
>
>
>
>
> --
> http://mysterybear.net
> https://soundcloud.com/mysterybear
> https://mysterybear.bandcamp.com
>
> http://recordings.irritablehedgehog.com/album/dave-seidel-60-hz
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd-dev] csound-extended

Tarmo Johannes-3

Hi,

 

just to report back that CsoundHtml5 built and worked fine on openSuse Leap 42.3, Qt 5.8 (and 5.9.1)

 

What do I need to do to build only vst opcodes from the other included subfolders?

 

greetings,

tarmo

 

On reede, 2. veebruar 2018 2:12.08 EET Michael Gogins wrote:

> Thanks for the info. You need to be on Ubuntu 17.10 to find the

> required Qt packages, are you? There probably is another way to get it

> to work if you are on another version.

>

> Best,

> Mike

>

> -----------------------------------------------------

> Michael Gogins

> Irreducible Productions

> http://michaelgogins.tumblr.com

> Michael dot Gogins at gmail dot com

>

> On Thu, Feb 1, 2018 at 6:24 PM, Dave Seidel <[hidden email]> wrote:

> > Sorry, I do think the llvm error is on my end -- I think cmake expects to

> > find files in /usr/share/llvm/... -- I have /usr/share/llvm-3.8 and

> > /usr/share/llvm-5.0. Probably I need to add a link.

> >

> > On Thu, Feb 1, 2018 at 5:22 PM, Dave Seidel <[hidden email]> wrote:

> >> Mike, I just gave it a try and have some notes.

> >>

> >> update-dependencies.sh:

> >> I had to install the p7zip-full package (I'm on Linux Mint) to get the 7z

> >> command that's used in the script. Once I did that, I was able to run the

> >> scrip to completion. Might be good to document that sudo is used, so most

> >> pople will be prompted for a password.

> >>

> >> build-linux.sh:

> >> This failed with the following output, implying I think that there are

> >> additional dependencies that I'm missing:

> >>

> >> CMake Error at /usr/share/llvm-3.8/cmake/LLVMConfig.cmake:178 (include):

> >> include could not find load file:

> >> /usr/share/llvm/cmake/LLVMExports.cmake

> >>

> >> Call Stack (most recent call first):

> >> CMakeLists.txt:103 (find_package)

> >>

> >> CMake Error at /usr/share/llvm-3.8/cmake/LLVMConfig.cmake:181 (include):

> >> include could not find load file:

> >> /usr/share/llvm/cmake/LLVM-Config.cmake

> >>

> >> Call Stack (most recent call first):

> >> CMakeLists.txt:103 (find_package)

> >>

> >> -- Could NOT find PORTSMF (missing: PORTSMF_INCLUDE_DIR)

> >> -- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8")

> >> -- Found PNG: /usr/lib/x86_64-linux-gnu/libpng.so (found version

> >> "1.2.54")

> >> -- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython2.7.so (found

> >> suitable version "2.7.12", minimum required is "2.7")

> >> CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Qt5/Qt5Config.cmake:26

> >>

> >> (find_package):

> >> Could not find a package configuration file provided by "Qt5WebEngine"

> >>

> >> with

> >>

> >> any of the following names:

> >> Qt5WebEngineConfig.cmake

> >> qt5webengine-config.cmake

> >>

> >> Add the installation prefix of "Qt5WebEngine" to CMAKE_PREFIX_PATH or

> >>

> >> set

> >>

> >> "Qt5WebEngine_DIR" to a directory containing one of the above files.

> >> If

> >> "Qt5WebEngine" provides a separate development package or SDK, be sure

> >>

> >> it

> >>

> >> has been installed.

> >>

> >> Call Stack (most recent call first):

> >> CMakeLists.txt:112 (find_package)

> >>

> >> -- Configuring incomplete, errors occurred!

> >> See also

> >> "/home/dave/src/csound-extended/build-linux/CMakeFiles/CMakeOutput.log".

> >> make: *** No targets specified and no makefile found. Stop.

> >> Installing...

> >> make: *** No rule to make target 'install'. Stop.

> >> Building packages...

> >> make: *** No rule to make target 'package'. Stop.

> >> Debian package contents:

> >> Running lintian...

> >> warning: cannot find binary, udeb or source package

> >> build-linux/csound-extended-6.11.0-beta-Linux.deb in lab (skipping)

> >> Finished building all for Linux.

> >>

> >> On Thu, Feb 1, 2018 at 4:42 PM, Dave Seidel <[hidden email]> wrote:

> >>> Thanks, Mike.

> >>>

> >>> On Thu, Feb 1, 2018 at 4:16 PM, Michael Gogins

> >>> <[hidden email]>

> >>>

> >>> wrote:

> >>>> As you know a number of components previously maintained in the Csound

> >>>> repository at https://github.com/csound/csound have been moved to

> >>>> external repositories.

> >>>>

> >>>> My share of these components may now be found in a new Github

> >>>> repository maintained by me at

> >>>> https://github.com/gogins/csound-extended. For more information on its

> >>>> contents, view the README.md there.

> >>>>

> >>>> At this time, I have released a beta version of the programs and

> >>>> libraries in csound-extended (including a build of Csound itself which

> >>>> is synchronized with the Csound repository) for Ubuntu 17.10, as well

> >>>> as an updated, signed version of the Csound for Android app (also

> >>>> published to the Google Play Store). This is a pre-release version and

> >>>> should only be installed locally (i.e., in your home directory or in

> >>>> /usr/local).

> >>>>

> >>>> Building from source _should_ be simple: clone the repository and run

> >>>> the build script.

> >>>>

> >>>> Please send any bug reports, comments, or suggestions to me.

> >>>>

> >>>> Regards,

> >>>> Mike

> >>>>

> >>>> -----------------------------------------------------

> >>>> Michael Gogins

> >>>> Irreducible Productions

> >>>> http://michaelgogins.tumblr.com

> >>>> Michael dot Gogins at gmail dot com

> >>>

> >>> --

> >>> http://mysterybear.net

> >>> https://soundcloud.com/mysterybear

> >>> https://mysterybear.bandcamp.com

> >>>

> >>> http://recordings.irritablehedgehog.com/album/dave-seidel-60-hz

> >>

> >> --

> >> http://mysterybear.net

> >> https://soundcloud.com/mysterybear

> >> https://mysterybear.bandcamp.com

> >>

> >> http://recordings.irritablehedgehog.com/album/dave-seidel-60-hz

> >

> > --

> > http://mysterybear.net

> > https://soundcloud.com/mysterybear

> > https://mysterybear.bandcamp.com

> >

> > http://recordings.irritablehedgehog.com/album/dave-seidel-60-hz