[Csnd-dev] Debian build problems again

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[Csnd-dev] Debian build problems again

Dave Seidel
Hi all. I just created a new debian instance, and am trying to get the csound build up and running. I'm getting the following error. I've reported the same error in the past, and previously resolved it by deleting CMakeCache.txt, but no such luck this time. I started from a fresh empty build directory.

-- Command "/usr/bin/swig2.0 -swiglib" failed with output:
-- Building C++ interface library.
-- Command "/usr/bin/swig2.0 -swiglib" failed with output:
-- Found SWIG: /usr/bin/swig2.0 (found suitable version "2.0.12", minimum required is "2.0") 
-- PYTHON_LIBRARY: /usr/lib/x86_64-linux-gnu/libpython2.7.so
-- BUILD_PYTHON_INTERFACE is enabled.
-- BUILD_JAVA_INTERFACE is enabled.
-- BUILD_LUA_INTERFACE is enabled.
-- SWIG_USE_FILE: 
CMake Error at interfaces/CMakeLists.txt:91 (include):
  include called with wrong number of arguments.  include() only takes one
  file.

CMake Error at interfaces/CMakeLists.txt:112 (swig_add_module):
  Unknown CMake command "swig_add_module".

-- Configuring incomplete, errors occurred!
See also "/home/dave/src/csound/csound/CMakeFiles/CMakeOutput.log".
See also "/home/dave/src/csound/csound/CMakeFiles/CMakeError.log".
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd-dev] Debian build problems again

Victor Lazzarini-2
CMake version?
========================
Prof. Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy,
Maynooth University,
Maynooth, Co Kildare, Ireland
Tel: 00 353 7086936
Fax: 00 353 1 7086952

> On 23 Mar 2018, at 12:10, Dave Seidel <[hidden email]> wrote:
>
> Hi all. I just created a new debian instance, and am trying to get the csound build up and running. I'm getting the following error. I've reported the same error in the past, and previously resolved it by deleting CMakeCache.txt, but no such luck this time. I started from a fresh empty build directory.
>
> -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
> -- Building C++ interface library.
> -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
> -- Found SWIG: /usr/bin/swig2.0 (found suitable version "2.0.12", minimum required is "2.0")
> -- PYTHON_LIBRARY: /usr/lib/x86_64-linux-gnu/libpython2.7.so
> -- BUILD_PYTHON_INTERFACE is enabled.
> -- BUILD_JAVA_INTERFACE is enabled.
> -- BUILD_LUA_INTERFACE is enabled.
> -- SWIG_USE_FILE:
> CMake Error at interfaces/CMakeLists.txt:91 (include):
>   include called with wrong number of arguments.  include() only takes one
>   file.
>
> CMake Error at interfaces/CMakeLists.txt:112 (swig_add_module):
>   Unknown CMake command "swig_add_module".
>
> -- Configuring incomplete, errors occurred!
> See also "/home/dave/src/csound/csound/CMakeFiles/CMakeOutput.log".
> See also "/home/dave/src/csound/csound/CMakeFiles/CMakeError.log".
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd-dev] Debian build problems again

Dave Seidel
3.7.2, as installed by apt-get install build-dep csound

On Fri, Mar 23, 2018 at 8:13 AM, Victor Lazzarini <[hidden email]> wrote:
CMake version?
========================
Prof. Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy,
Maynooth University,
Maynooth, Co Kildare, Ireland
Tel: 00 353 7086936
Fax: 00 353 1 7086952

> On 23 Mar 2018, at 12:10, Dave Seidel <[hidden email]> wrote:
>
> Hi all. I just created a new debian instance, and am trying to get the csound build up and running. I'm getting the following error. I've reported the same error in the past, and previously resolved it by deleting CMakeCache.txt, but no such luck this time. I started from a fresh empty build directory.
>
> -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
> -- Building C++ interface library.
> -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
> -- Found SWIG: /usr/bin/swig2.0 (found suitable version "2.0.12", minimum required is "2.0")
> -- PYTHON_LIBRARY: /usr/lib/x86_64-linux-gnu/libpython2.7.so
> -- BUILD_PYTHON_INTERFACE is enabled.
> -- BUILD_JAVA_INTERFACE is enabled.
> -- BUILD_LUA_INTERFACE is enabled.
> -- SWIG_USE_FILE:
> CMake Error at interfaces/CMakeLists.txt:91 (include):
>   include called with wrong number of arguments.  include() only takes one
>   file.
>
> CMake Error at interfaces/CMakeLists.txt:112 (swig_add_module):
>   Unknown CMake command "swig_add_module".
>
> -- Configuring incomplete, errors occurred!
> See also "/home/dave/src/csound/csound/CMakeFiles/CMakeOutput.log".
> See also "/home/dave/src/csound/csound/CMakeFiles/CMakeError.log".



--
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd-dev] Debian build problems again

Steven Yi
The error reported has:

-- SWIG_USE_FILE:
CMake Error at interfaces/CMakeLists.txt:91 (include):
  include called with wrong number of arguments.  include() only takes one
  file.

and the cmake file has:

    message(STATUS "SWIG_USE_FILE: " ${SWIG_USE_FILE})
    include(${SWIG_USE_FILE})

and SWIG_USE_FILE is set from Cmake's FindSWIG.cmake module:

    if(SWIG_DIR)
      set(SWIG_USE_FILE ${CMAKE_CURRENT_LIST_DIR}/UseSWIG.cmake)


My guess, check if swig is installed and, if so, what version.
(Regardless, our Cmake files should be fixed to check better for this
situation.)




On Fri, Mar 23, 2018 at 8:22 AM, Dave Seidel <[hidden email]> wrote:

> 3.7.2, as installed by apt-get install build-dep csound
>
> On Fri, Mar 23, 2018 at 8:13 AM, Victor Lazzarini <[hidden email]>
> wrote:
>>
>> CMake version?
>> ========================
>> Prof. Victor Lazzarini
>> Dean of Arts, Celtic Studies, and Philosophy,
>> Maynooth University,
>> Maynooth, Co Kildare, Ireland
>> Tel: 00 353 7086936
>> Fax: 00 353 1 7086952
>>
>> > On 23 Mar 2018, at 12:10, Dave Seidel <[hidden email]> wrote:
>> >
>> > Hi all. I just created a new debian instance, and am trying to get the
>> > csound build up and running. I'm getting the following error. I've reported
>> > the same error in the past, and previously resolved it by deleting
>> > CMakeCache.txt, but no such luck this time. I started from a fresh empty
>> > build directory.
>> >
>> > -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
>> > -- Building C++ interface library.
>> > -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
>> > -- Found SWIG: /usr/bin/swig2.0 (found suitable version "2.0.12",
>> > minimum required is "2.0")
>> > -- PYTHON_LIBRARY: /usr/lib/x86_64-linux-gnu/libpython2.7.so
>> > -- BUILD_PYTHON_INTERFACE is enabled.
>> > -- BUILD_JAVA_INTERFACE is enabled.
>> > -- BUILD_LUA_INTERFACE is enabled.
>> > -- SWIG_USE_FILE:
>> > CMake Error at interfaces/CMakeLists.txt:91 (include):
>> >   include called with wrong number of arguments.  include() only takes
>> > one
>> >   file.
>> >
>> > CMake Error at interfaces/CMakeLists.txt:112 (swig_add_module):
>> >   Unknown CMake command "swig_add_module".
>> >
>> > -- Configuring incomplete, errors occurred!
>> > See also "/home/dave/src/csound/csound/CMakeFiles/CMakeOutput.log".
>> > See also "/home/dave/src/csound/csound/CMakeFiles/CMakeError.log".
>
>
>
>
> --
> http://mysterybear.net
> https://soundcloud.com/mysterybear
> https://mysterybear.bandcamp.com
>
> http://recordings.irritablehedgehog.com/album/dave-seidel-60-hz
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd-dev] Debian build problems again

jpff
In reply to this post by Dave Seidel
My Debian build system has cmake 3.0.2.  which Debian?
OTOH I have swig3.0.2

⁣Sent from TypeApp ​

On Mar 23, 2018, 12:23, at 12:23, Dave Seidel <[hidden email]> wrote:

>3.7.2, as installed by apt-get install build-dep csound
>
>On Fri, Mar 23, 2018 at 8:13 AM, Victor Lazzarini
><[hidden email]>
>wrote:
>
>> CMake version?
>> ========================
>> Prof. Victor Lazzarini
>> Dean of Arts, Celtic Studies, and Philosophy,
>> Maynooth University,
>> Maynooth, Co Kildare, Ireland
>> Tel: 00 353 7086936
>> Fax: 00 353 1 7086952
>>
>> > On 23 Mar 2018, at 12:10, Dave Seidel <[hidden email]>
>wrote:
>> >
>> > Hi all. I just created a new debian instance, and am trying to get
>the
>> csound build up and running. I'm getting the following error. I've
>reported
>> the same error in the past, and previously resolved it by deleting
>> CMakeCache.txt, but no such luck this time. I started from a fresh
>empty
>> build directory.
>> >
>> > -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
>> > -- Building C++ interface library.
>> > -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
>> > -- Found SWIG: /usr/bin/swig2.0 (found suitable version "2.0.12",
>> minimum required is "2.0")
>> > -- PYTHON_LIBRARY: /usr/lib/x86_64-linux-gnu/libpython2.7.so
>> > -- BUILD_PYTHON_INTERFACE is enabled.
>> > -- BUILD_JAVA_INTERFACE is enabled.
>> > -- BUILD_LUA_INTERFACE is enabled.
>> > -- SWIG_USE_FILE:
>> > CMake Error at interfaces/CMakeLists.txt:91 (include):
>> >   include called with wrong number of arguments.  include() only
>takes
>> one
>> >   file.
>> >
>> > CMake Error at interfaces/CMakeLists.txt:112 (swig_add_module):
>> >   Unknown CMake command "swig_add_module".
>> >
>> > -- Configuring incomplete, errors occurred!
>> > See also "/home/dave/src/csound/csound/CMakeFiles/CMakeOutput.log".
>> > See also "/home/dave/src/csound/csound/CMakeFiles/CMakeError.log".
>>
>
>
>
>--
>http://mysterybear.net
>https://soundcloud.com/mysterybear
>https://mysterybear.bandcamp.com
>
>http://recordings.irritablehedgehog.com/album/dave-seidel-60-hz
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd-dev] Debian build problems again

Dave Seidel
In reply to this post by Dave Seidel
Victor, sorry for wasting your time again. I had copied over the source tree from a different system, and when I wiped it out and tried again from a fresh clone, the problem went away.

On Fri, Mar 23, 2018 at 8:22 AM, Dave Seidel <[hidden email]> wrote:
3.7.2, as installed by apt-get install build-dep csound

On Fri, Mar 23, 2018 at 8:13 AM, Victor Lazzarini <[hidden email]> wrote:
CMake version?
========================
Prof. Victor Lazzarini
Dean of Arts, Celtic Studies, and Philosophy,
Maynooth University,
Maynooth, Co Kildare, Ireland
Tel: 00 353 7086936
Fax: 00 353 1 7086952

> On 23 Mar 2018, at 12:10, Dave Seidel <[hidden email]> wrote:
>
> Hi all. I just created a new debian instance, and am trying to get the csound build up and running. I'm getting the following error. I've reported the same error in the past, and previously resolved it by deleting CMakeCache.txt, but no such luck this time. I started from a fresh empty build directory.
>
> -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
> -- Building C++ interface library.
> -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
> -- Found SWIG: /usr/bin/swig2.0 (found suitable version "2.0.12", minimum required is "2.0")
> -- PYTHON_LIBRARY: /usr/lib/x86_64-linux-gnu/libpython2.7.so
> -- BUILD_PYTHON_INTERFACE is enabled.
> -- BUILD_JAVA_INTERFACE is enabled.
> -- BUILD_LUA_INTERFACE is enabled.
> -- SWIG_USE_FILE:
> CMake Error at interfaces/CMakeLists.txt:91 (include):
>   include called with wrong number of arguments.  include() only takes one
>   file.
>
> CMake Error at interfaces/CMakeLists.txt:112 (swig_add_module):
>   Unknown CMake command "swig_add_module".
>
> -- Configuring incomplete, errors occurred!
> See also "/home/dave/src/csound/csound/CMakeFiles/CMakeOutput.log".
> See also "/home/dave/src/csound/csound/CMakeFiles/CMakeError.log".



--



--
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd-dev] Debian build problems again

Dave Seidel
In reply to this post by jpff
See my previous message, solved. I have swig 3.0.10 btw. Thanks, gents.

On Fri, Mar 23, 2018 at 8:35 AM, John ff <[hidden email]> wrote:
My Debian build system has cmake 3.0.2.  which Debian?
OTOH I have swig3.0.2

⁣Sent from TypeApp ​

On Mar 23, 2018, 12:23, at 12:23, Dave Seidel <[hidden email]> wrote:
>3.7.2, as installed by apt-get install build-dep csound
>
>On Fri, Mar 23, 2018 at 8:13 AM, Victor Lazzarini
><[hidden email]>
>wrote:
>
>> CMake version?
>> ========================
>> Prof. Victor Lazzarini
>> Dean of Arts, Celtic Studies, and Philosophy,
>> Maynooth University,
>> Maynooth, Co Kildare, Ireland
>> Tel: 00 353 7086936
>> Fax: 00 353 1 7086952
>>
>> > On 23 Mar 2018, at 12:10, Dave Seidel <[hidden email]>
>wrote:
>> >
>> > Hi all. I just created a new debian instance, and am trying to get
>the
>> csound build up and running. I'm getting the following error. I've
>reported
>> the same error in the past, and previously resolved it by deleting
>> CMakeCache.txt, but no such luck this time. I started from a fresh
>empty
>> build directory.
>> >
>> > -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
>> > -- Building C++ interface library.
>> > -- Command "/usr/bin/swig2.0 -swiglib" failed with output:
>> > -- Found SWIG: /usr/bin/swig2.0 (found suitable version "2.0.12",
>> minimum required is "2.0")
>> > -- PYTHON_LIBRARY: /usr/lib/x86_64-linux-gnu/libpython2.7.so
>> > -- BUILD_PYTHON_INTERFACE is enabled.
>> > -- BUILD_JAVA_INTERFACE is enabled.
>> > -- BUILD_LUA_INTERFACE is enabled.
>> > -- SWIG_USE_FILE:
>> > CMake Error at interfaces/CMakeLists.txt:91 (include):
>> >   include called with wrong number of arguments.  include() only
>takes
>> one
>> >   file.
>> >
>> > CMake Error at interfaces/CMakeLists.txt:112 (swig_add_module):
>> >   Unknown CMake command "swig_add_module".
>> >
>> > -- Configuring incomplete, errors occurred!
>> > See also "/home/dave/src/csound/csound/CMakeFiles/CMakeOutput.log".
>> > See also "/home/dave/src/csound/csound/CMakeFiles/CMakeError.log".
>>
>
>
>
>--
>http://mysterybear.net
>https://soundcloud.com/mysterybear
>https://mysterybear.bandcamp.com
>
>http://recordings.irritablehedgehog.com/album/dave-seidel-60-hz



--