[Csnd] csd with connect opcodes crashes on RPi

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Csnd] csd with connect opcodes crashes on RPi

zappfinger
The attached csd gives a segmentation fault on the Raspberry Pi (Csound
6.07):

.....
Created instance 0x1fbdde8 of 1 instances of outlet 110:leftout
Created instance 0x1fbdf08 of 1 instances of outlet 110:rightout
new alloc for instr 200:
BEGAN Inleta::init()...
sourceOutlets: 0x0
sourceOutlets: 0x1f0e6f0
Created instance 0x1fbe3c0 of inlet 200:leftin
Connected instances of outlet 110:leftout to instance 0x1fbe3c0 of inlet
200:leftin.
ENDED Inleta::init().
BEGAN Inleta::init()...
sourceOutlets: 0x0
sourceOutlets: 0x1f4dc20
Created instance 0x1fbe4e8 of inlet 200:rightin
Connected instances of outlet 110:rightout to instance 0x1fbe4e8 of
inlet 200:rightin.
ENDED Inleta::init().
new alloc for instr 1:
   rtevent:       T  0.501 TT  0.501 M:  0.00000  0.00000
new alloc for instr 9:

csound command: Segmentation fault
Segmentation fault



Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

testbase.csd (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] csd with connect opcodes crashes on RPi

jpff
Seemed to run for me in latest git on Linx; no segfault anyway

On Tue, 4 Apr 2017, Richard wrote:

> The attached csd gives a segmentation fault on the Raspberry Pi (Csound
> 6.07):
>
> .....
> Created instance 0x1fbdde8 of 1 instances of outlet 110:leftout
> Created instance 0x1fbdf08 of 1 instances of outlet 110:rightout
> new alloc for instr 200:
> BEGAN Inleta::init()...
> sourceOutlets: 0x0
> sourceOutlets: 0x1f0e6f0
> Created instance 0x1fbe3c0 of inlet 200:leftin
> Connected instances of outlet 110:leftout to instance 0x1fbe3c0 of inlet
> 200:leftin.
> ENDED Inleta::init().
> BEGAN Inleta::init()...
> sourceOutlets: 0x0
> sourceOutlets: 0x1f4dc20
> Created instance 0x1fbe4e8 of inlet 200:rightin
> Connected instances of outlet 110:rightout to instance 0x1fbe4e8 of inlet
> 200:rightin.
> ENDED Inleta::init().
> new alloc for instr 1:
>  rtevent:       T  0.501 TT  0.501 M:  0.00000  0.00000
> new alloc for instr 9:
>
> csound command: Segmentation fault
> Segmentation fault
>
>
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>       https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here
>

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] csd with connect opcodes crashes on RPi

zappfinger
It also runs for me on OS X (Csound 6.08) On my Pi I have an older COSMO
image with Csound 6.07



On 04/04/17 15:04, jpff wrote:

> Seemed to run for me in latest git on Linx; no segfault anyway
>
> On Tue, 4 Apr 2017, Richard wrote:
>
>> The attached csd gives a segmentation fault on the Raspberry Pi
>> (Csound 6.07):
>>
>> .....
>> Created instance 0x1fbdde8 of 1 instances of outlet 110:leftout
>> Created instance 0x1fbdf08 of 1 instances of outlet 110:rightout
>> new alloc for instr 200:
>> BEGAN Inleta::init()...
>> sourceOutlets: 0x0
>> sourceOutlets: 0x1f0e6f0
>> Created instance 0x1fbe3c0 of inlet 200:leftin
>> Connected instances of outlet 110:leftout to instance 0x1fbe3c0 of
>> inlet 200:leftin.
>> ENDED Inleta::init().
>> BEGAN Inleta::init()...
>> sourceOutlets: 0x0
>> sourceOutlets: 0x1f4dc20
>> Created instance 0x1fbe4e8 of inlet 200:rightin
>> Connected instances of outlet 110:rightout to instance 0x1fbe4e8 of
>> inlet 200:rightin.
>> ENDED Inleta::init().
>> new alloc for instr 1:
>>  rtevent:       T  0.501 TT  0.501 M:  0.00000  0.00000
>> new alloc for instr 9:
>>
>> csound command: Segmentation fault
>> Segmentation fault
>>
>>
>>
>> Csound mailing list
>> [hidden email]
>> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>> Send bugs reports to
>>       https://github.com/csound/csound/issues
>> Discussions of bugs and features can be posted here
>>
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>        https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] csd with connect opcodes crashes on RPi

Bernt Isak Wærstad
The latest COSMO image has 6.08 (http://cosmoproject.github.io/links/)

On 4 April 2017 at 15:11, Richard <[hidden email]> wrote:
It also runs for me on OS X (Csound 6.08) On my Pi I have an older COSMO image with Csound 6.07




On 04/04/17 15:04, jpff wrote:
Seemed to run for me in latest git on Linx; no segfault anyway

On Tue, 4 Apr 2017, Richard wrote:

The attached csd gives a segmentation fault on the Raspberry Pi (Csound 6.07):

.....
Created instance 0x1fbdde8 of 1 instances of outlet 110:leftout
Created instance 0x1fbdf08 of 1 instances of outlet 110:rightout
new alloc for instr 200:
BEGAN Inleta::init()...
sourceOutlets: 0x0
sourceOutlets: 0x1f0e6f0
Created instance 0x1fbe3c0 of inlet 200:leftin
Connected instances of outlet 110:leftout to instance 0x1fbe3c0 of inlet 200:leftin.
ENDED Inleta::init().
BEGAN Inleta::init()...
sourceOutlets: 0x0
sourceOutlets: 0x1f4dc20
Created instance 0x1fbe4e8 of inlet 200:rightin
Connected instances of outlet 110:rightout to instance 0x1fbe4e8 of inlet 200:rightin.
ENDED Inleta::init().
new alloc for instr 1:
 rtevent:       T  0.501 TT  0.501 M:  0.00000  0.00000
new alloc for instr 9:

csound command: Segmentation fault
Segmentation fault



Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
      https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here



--
Mvh.

Bernt Isak Wærstad


Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] csd with connect opcodes crashes on RPi

zappfinger

I installed the latest image now, but it still crashes with Csound 6.08...


On 04/04/17 16:01, Bernt Isak Wærstad wrote:
The latest COSMO image has 6.08 (http://cosmoproject.github.io/links/)

On 4 April 2017 at 15:11, Richard <[hidden email]> wrote:
It also runs for me on OS X (Csound 6.08) On my Pi I have an older COSMO image with Csound 6.07




On 04/04/17 15:04, jpff wrote:
Seemed to run for me in latest git on Linx; no segfault anyway

On Tue, 4 Apr 2017, Richard wrote:

The attached csd gives a segmentation fault on the Raspberry Pi (Csound 6.07):

.....
Created instance 0x1fbdde8 of 1 instances of outlet 110:leftout
Created instance 0x1fbdf08 of 1 instances of outlet 110:rightout
new alloc for instr 200:
BEGAN Inleta::init()...
sourceOutlets: 0x0
sourceOutlets: 0x1f0e6f0
Created instance 0x1fbe3c0 of inlet 200:leftin
Connected instances of outlet 110:leftout to instance 0x1fbe3c0 of inlet 200:leftin.
ENDED Inleta::init().
BEGAN Inleta::init()...
sourceOutlets: 0x0
sourceOutlets: 0x1f4dc20
Created instance 0x1fbe4e8 of inlet 200:rightin
Connected instances of outlet 110:rightout to instance 0x1fbe4e8 of inlet 200:rightin.
ENDED Inleta::init().
new alloc for instr 1:
 rtevent:       T  0.501 TT  0.501 M:  0.00000  0.00000
new alloc for instr 9:

csound command: Segmentation fault
Segmentation fault



Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
      https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here



--
Mvh.

Bernt Isak Wærstad


Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] csd with connect opcodes crashes on RPi

zappfinger
In reply to this post by Bernt Isak Wærstad

It looks it has nothing to do with the connect opcodes. I removed them and it still crashes on the RPi. Attached is a more minimal test.csd. It runs fine on OS X, but not on the Pi.
I can't see what is wrong with it...


On 04/04/17 16:01, Bernt Isak Wærstad wrote:
The latest COSMO image has 6.08 (http://cosmoproject.github.io/links/)

On 4 April 2017 at 15:11, Richard <[hidden email]> wrote:
It also runs for me on OS X (Csound 6.08) On my Pi I have an older COSMO image with Csound 6.07




On 04/04/17 15:04, jpff wrote:
Seemed to run for me in latest git on Linx; no segfault anyway

On Tue, 4 Apr 2017, Richard wrote:

The attached csd gives a segmentation fault on the Raspberry Pi (Csound 6.07):

.....
Created instance 0x1fbdde8 of 1 instances of outlet 110:leftout
Created instance 0x1fbdf08 of 1 instances of outlet 110:rightout
new alloc for instr 200:
BEGAN Inleta::init()...
sourceOutlets: 0x0
sourceOutlets: 0x1f0e6f0
Created instance 0x1fbe3c0 of inlet 200:leftin
Connected instances of outlet 110:leftout to instance 0x1fbe3c0 of inlet 200:leftin.
ENDED Inleta::init().
BEGAN Inleta::init()...
sourceOutlets: 0x0
sourceOutlets: 0x1f4dc20
Created instance 0x1fbe4e8 of inlet 200:rightin
Connected instances of outlet 110:rightout to instance 0x1fbe4e8 of inlet 200:rightin.
ENDED Inleta::init().
new alloc for instr 1:
 rtevent:       T  0.501 TT  0.501 M:  0.00000  0.00000
new alloc for instr 9:

csound command: Segmentation fault
Segmentation fault



Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
      https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here



--
Mvh.

Bernt Isak Wærstad


Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

test.csd (3K) Download Attachment
Loading...