[Csnd] bug in output when csound cleans up

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[Csnd] bug in output when csound cleans up

akjmicro
Hi all (and esp. devs):

Using gdb, I was able to locate that something is amiss in 'csoundDestroyModules' that ends up printing a newline and 3 spaces while csound quits. Well, at least here on my system. I don't have debugging symbols and line numbers available in gdb, but stepping through, I know it's there somewhere.

In gdb, here's what I'm seeing:

...
Score finished in csoundPerform().
inactive allocs returned to freespace
end of score.    overall amps:  0.08499  0.09494
   overall samples out of range:        0        0
0 errors in performance
Elapsed time at end of performance: real: 4.377s, CPU: 0.439s
724 512 sample blks of 64-bit floats written to dac
   [Inferior 1 (process 16968) exited normally]
(gdb) 

Right before "[Inferior..." you'll notice the thing that is triggering my annoyed state...the 3 spaces.

Thanks for having a look.


Aaron Krister Johnson
http://www.untwelve.org

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] bug in output when csound cleans up

jpff
I cannot reproduce this.  Does it happen on all inputs of specific ones?

⁣Sent from TypeApp ​

On Jun 14, 2018, 02:12, at 02:12, Aaron Krister Johnson <[hidden email]> wrote:

>Hi all (and esp. devs):
>
>Using gdb, I was able to locate that something is amiss in
>'csoundDestroyModules' that ends up printing a newline and 3 spaces
>while
>csound quits. Well, at least here on my system. I don't have debugging
>symbols and line numbers available in gdb, but stepping through, I know
>it's there somewhere.
>
>In gdb, here's what I'm seeing:
>
>...
>Score finished in csoundPerform().
>inactive allocs returned to freespace
>end of score.    overall amps:  0.08499  0.09494
>   overall samples out of range:        0        0
>0 errors in performance
>Elapsed time at end of performance: real: 4.377s, CPU: 0.439s
>724 512 sample blks of 64-bit floats written to dac
>   [Inferior 1 (process 16968) exited normally]
>(gdb)
>
>Right before "[Inferior..." you'll notice the thing that is triggering
>my
>annoyed state...the 3 spaces.
>
>Thanks for having a look.
>
>
>Aaron Krister Johnson
>http://www.untwelve.org
>
>Csound mailing list
>[hidden email]
>https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>Send bugs reports to
>        https://github.com/csound/csound/issues
>Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] bug in output when csound cleans up

akjmicro
Hi John,

It happens, it seems, on closing for any and all inputs.

I'm wondering if there's some corruption in a local c-lib version of mine. Gdb reports a line where I see the 3-space gap all of a sudden, and it happens in reference to 'malloc.c'

Best,
AKJ


On Jun 14, 2018 7:29 AM, "John ff" <[hidden email]> wrote:
I cannot reproduce this.  Does it happen on all inputs of specific ones?

⁣Sent from TypeApp ​


On Jun 14, 2018, 02:12, at 02:12, Aaron Krister Johnson <[hidden email]> wrote:
>Hi all (and esp. devs):
>
>Using gdb, I was able to locate that something is amiss in
>'csoundDestroyModules' that ends up printing a newline and 3 spaces
>while
>csound quits. Well, at least here on my system. I don't have debugging
>symbols and line numbers available in gdb, but stepping through, I know
>it's there somewhere.
>
>In gdb, here's what I'm seeing:
>
>...
>Score finished in csoundPerform().
>inactive allocs returned to freespace
>end of score.    overall amps:  0.08499  0.09494
>   overall samples out of range:        0        0
>0 errors in performance
>Elapsed time at end of performance: real: 4.377s, CPU: 0.439s
>724 512 sample blks of 64-bit floats written to dac
>   [Inferior 1 (process 16968) exited normally]
>(gdb)
>
>Right before "[Inferior..." you'll notice the thing that is triggering
>my
>annoyed state...the 3 spaces.
>
>Thanks for having a look.
>
>
>Aaron Krister Johnson
>http://www.untwelve.org
>
>Csound mailing list
>[hidden email]
>https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>Send bugs reports to
>        https://github.com/csound/csound/issues
>Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] bug in output when csound cleans up

jpff
The malloc.c file is not csound.  Do you have valgrind?



Sent from Blue
n <[hidden email]>  wrote:
Hi John,

It happens, it seems, on closing for any and all inputs.

I'm wondering if there's some corruption in a local c-lib version of mine. Gdb reports a line where I see the 3-space gap all of a sudden, and it happens in reference to 'malloc.c'

Best,
AKJ


On Jun 14, 2018 7:29 AM, "John ff" <[hidden email]> wrote:
I cannot reproduce this.  Does it happen on all inputs of specific ones?

⁣Sent from TypeApp ​


On Jun 14, 2018, 02:12, at 02:12, Aaron Krister Johnson <[hidden email]> wrote:
>Hi all (and esp. devs):
>
>Using gdb, I was able to locate that something is amiss in
>'csoundDestroyModules' that ends up printing a newline and 3 spaces
>while
>csound quits. Well, at least here on my system. I don't have debugging
>symbols and line numbers available in gdb, but stepping through, I know
>it's there somewhere.
>
>In gdb, here's what I'm seeing:
>
>...
>Score finished in csoundPerform().
>inactive allocs returned to freespace
>end of score.    overall amps:  0.08499  0.09494
>   overall samples out of range:        0        0
>0 errors in performance
>Elapsed time at end of performance: real: 4.377s, CPU: 0.439s
>724 512 sample blks of 64-bit floats written to dac
>   [Inferior 1 (process 16968) exited normally]
>(gdb)
>
>Right before "[Inferior..." you'll notice the thing that is triggering
>my
>annoyed state...the 3 spaces.
>
>Thanks for having a look.
>
>
>Aaron Krister Johnson
>http://www.untwelve.org
>
>Csound mailing list
>[hidden email]
>https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>Send bugs reports to
>        https://github.com/csound/csound/issues
>Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] bug in output when csound cleans up

akjmicro
Yes, understood...I knew :)

Will look more into it when I have a moment, with valgrind.

OTOH, maybe I can update the c lib on my system, if available. Might be a bug peculiar to my particular snapshot.


On Thu, Jun 14, 2018, 8:50 AM John ff <[hidden email]> wrote:
The malloc.c file is not csound.  Do you have valgrind?



Sent from Blue
n <[hidden email]>  wrote:
Hi John,

It happens, it seems, on closing for any and all inputs.

I'm wondering if there's some corruption in a local c-lib version of mine. Gdb reports a line where I see the 3-space gap all of a sudden, and it happens in reference to 'malloc.c'

Best,
AKJ


On Jun 14, 2018 7:29 AM, "John ff" <[hidden email]> wrote:
I cannot reproduce this.  Does it happen on all inputs of specific ones?

⁣Sent from TypeApp ​


On Jun 14, 2018, 02:12, at 02:12, Aaron Krister Johnson <[hidden email]> wrote:
>Hi all (and esp. devs):
>
>Using gdb, I was able to locate that something is amiss in
>'csoundDestroyModules' that ends up printing a newline and 3 spaces
>while
>csound quits. Well, at least here on my system. I don't have debugging
>symbols and line numbers available in gdb, but stepping through, I know
>it's there somewhere.
>
>In gdb, here's what I'm seeing:
>
>...
>Score finished in csoundPerform().
>inactive allocs returned to freespace
>end of score.    overall amps:  0.08499  0.09494
>   overall samples out of range:        0        0
>0 errors in performance
>Elapsed time at end of performance: real: 4.377s, CPU: 0.439s
>724 512 sample blks of 64-bit floats written to dac
>   [Inferior 1 (process 16968) exited normally]
>(gdb)
>
>Right before "[Inferior..." you'll notice the thing that is triggering
>my
>annoyed state...the 3 spaces.
>
>Thanks for having a look.
>
>
>Aaron Krister Johnson
>http://www.untwelve.org
>
>Csound mailing list
>[hidden email]
>https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>Send bugs reports to
>        https://github.com/csound/csound/issues
>Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here