[Csnd] Zak Clear problem

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Csnd] Zak Clear problem

hlolli
So I was playing some samples with loscil and without getting any nan, zacl decided to die on me (csound continues to run but procuded no sound). It's bit important that this opcode is stable, otherwise I can just change to ga_ variables.

 PERF ERROR in instr 10000: zacl first or last < 0. Not clearing.
zacl 0 4
   note aborted

Im running on MacOsX

--Csound version 6.08 (double samples) Nov 23 2016 

[commit: a1159a1e12a1095c4607f7162c44b196f5143959]

libsndfile-1.0.25


(as I post this I notice that I may want to try newer version).

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Zak Clear problem

jpff
Ay cane of seeing the actual orc?  The ode is clear and simple -- that
message only happens if (first < 0) || (last < 0)

On Fri, 17 Mar 2017, Hlöðver Sigurðsson wrote:

> So I was playing some samples with loscil and without getting any nan, zacl
> decided to die on me (csound continues to run but procuded no sound). It's bit
> important that this opcode is stable, otherwise I can just change to ga_
> variables.
>
>  PERF ERROR in instr 10000: zacl first or last < 0. Not clearing.
> zacl 0 4
>    note aborted
>
> Im running on MacOsX
>
> --Csound version 6.08 (double samples) Nov 23 2016 
>
> [commit: a1159a1e12a1095c4607f7162c44b196f5143959]
>
> libsndfile-1.0.25
>
>
> (as I post this I notice that I may want to try newer version).
>
> Csound mailing list [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to
> https://github.com/csound/csound/issues Discussions of bugs and features can
> be posted here
>
Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Zak Clear problem

hlolli
Happened few other times as well, one was just when I was using the csound-api compiling sample tables(via CompileOrc), wasn't playing any sound, but the performance had still started. I think this is more connected to the fact Im using nodejs csound-api. So before I should wolf wolf, I should have a more solid understanding what's causing this. All I worry is that it would happen during music performance so I thought I'd ask if someone else had encountered this.

2017-03-17 17:59 GMT+01:00 jpff <[hidden email]>:
Ay cane of seeing the actual orc?  The ode is clear and simple -- that message only happens if (first < 0) || (last < 0)


On Fri, 17 Mar 2017, Hlöðver Sigurðsson wrote:

So I was playing some samples with loscil and without getting any nan, zacl
decided to die on me (csound continues to run but procuded no sound). It's bit
important that this opcode is stable, otherwise I can just change to ga_
variables.

 PERF ERROR in instr 10000: zacl first or last < 0. Not clearing.
zacl 0 4
   note aborted

Im running on MacOsX

--Csound version 6.08 (double samples) Nov 23 2016 

[commit: a1159a1e12a1095c4607f7162c44b196f5143959]

libsndfile-1.0.25


(as I post this I notice that I may want to try newer version).

Csound mailing list [hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to
https://github.com/csound/csound/issues Discussions of bugs and features can
be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Zak Clear problem

Oeyvind Brandtsegg-3
Hi Hlöðver,
any reason why you would not rather use chn than zak?
It seems zak is not so actively used anymore.
Oeyvind

2017-03-17 12:53 GMT-07:00 Hlöðver Sigurðsson <[hidden email]>:
Happened few other times as well, one was just when I was using the csound-api compiling sample tables(via CompileOrc), wasn't playing any sound, but the performance had still started. I think this is more connected to the fact Im using nodejs csound-api. So before I should wolf wolf, I should have a more solid understanding what's causing this. All I worry is that it would happen during music performance so I thought I'd ask if someone else had encountered this.

2017-03-17 17:59 GMT+01:00 jpff <[hidden email]>:
Ay cane of seeing the actual orc?  The ode is clear and simple -- that message only happens if (first < 0) || (last < 0)


On Fri, 17 Mar 2017, Hlöðver Sigurðsson wrote:

So I was playing some samples with loscil and without getting any nan, zacl
decided to die on me (csound continues to run but procuded no sound). It's bit
important that this opcode is stable, otherwise I can just change to ga_
variables.

 PERF ERROR in instr 10000: zacl first or last < 0. Not clearing.
zacl 0 4
   note aborted

Im running on MacOsX

--Csound version 6.08 (double samples) Nov 23 2016 

[commit: a1159a1e12a1095c4607f7162c44b196f5143959]

libsndfile-1.0.25


(as I post this I notice that I may want to try newer version).

Csound mailing list [hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to
https://github.com/csound/csound/issues Discussions of bugs and features can
be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here



--
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Zak Clear problem

hlolli
No specific reason, didn't think of chn for anything else than export/import of data between api/csound.

Thanks for pointing that out Oeyvind,
Skål!

2017-03-17 21:17 GMT+01:00 Oeyvind Brandtsegg <[hidden email]>:
Hi Hlöðver,
any reason why you would not rather use chn than zak?
It seems zak is not so actively used anymore.
Oeyvind

2017-03-17 12:53 GMT-07:00 Hlöðver Sigurðsson <[hidden email]>:
Happened few other times as well, one was just when I was using the csound-api compiling sample tables(via CompileOrc), wasn't playing any sound, but the performance had still started. I think this is more connected to the fact Im using nodejs csound-api. So before I should wolf wolf, I should have a more solid understanding what's causing this. All I worry is that it would happen during music performance so I thought I'd ask if someone else had encountered this.

2017-03-17 17:59 GMT+01:00 jpff <[hidden email]>:
Ay cane of seeing the actual orc?  The ode is clear and simple -- that message only happens if (first < 0) || (last < 0)


On Fri, 17 Mar 2017, Hlöðver Sigurðsson wrote:

So I was playing some samples with loscil and without getting any nan, zacl
decided to die on me (csound continues to run but procuded no sound). It's bit
important that this opcode is stable, otherwise I can just change to ga_
variables.

 PERF ERROR in instr 10000: zacl first or last < 0. Not clearing.
zacl 0 4
   note aborted

Im running on MacOsX

--Csound version 6.08 (double samples) Nov 23 2016 

[commit: a1159a1e12a1095c4607f7162c44b196f5143959]

libsndfile-1.0.25


(as I post this I notice that I may want to try newer version).

Csound mailing list [hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to
https://github.com/csound/csound/issues Discussions of bugs and features can
be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here



--
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Zak Clear problem

Oeyvind Brandtsegg-3
Ah, good. 
It is my preferred methods for transporting audio between instruments,
and I find it very convenient that I don't have to declare channels, just start using them (either write or read) and it will be created if it does not already exist).

Skål indeed!

2017-03-17 13:28 GMT-07:00 Hlöðver Sigurðsson <[hidden email]>:
No specific reason, didn't think of chn for anything else than export/import of data between api/csound.

Thanks for pointing that out Oeyvind,
Skål!

2017-03-17 21:17 GMT+01:00 Oeyvind Brandtsegg <[hidden email]>:
Hi Hlöðver,
any reason why you would not rather use chn than zak?
It seems zak is not so actively used anymore.
Oeyvind

2017-03-17 12:53 GMT-07:00 Hlöðver Sigurðsson <[hidden email]>:
Happened few other times as well, one was just when I was using the csound-api compiling sample tables(via CompileOrc), wasn't playing any sound, but the performance had still started. I think this is more connected to the fact Im using nodejs csound-api. So before I should wolf wolf, I should have a more solid understanding what's causing this. All I worry is that it would happen during music performance so I thought I'd ask if someone else had encountered this.

2017-03-17 17:59 GMT+01:00 jpff <[hidden email]>:
Ay cane of seeing the actual orc?  The ode is clear and simple -- that message only happens if (first < 0) || (last < 0)


On Fri, 17 Mar 2017, Hlöðver Sigurðsson wrote:

So I was playing some samples with loscil and without getting any nan, zacl
decided to die on me (csound continues to run but procuded no sound). It's bit
important that this opcode is stable, otherwise I can just change to ga_
variables.

 PERF ERROR in instr 10000: zacl first or last < 0. Not clearing.
zacl 0 4
   note aborted

Im running on MacOsX

--Csound version 6.08 (double samples) Nov 23 2016 

[commit: a1159a1e12a1095c4607f7162c44b196f5143959]

libsndfile-1.0.25


(as I post this I notice that I may want to try newer version).

Csound mailing list [hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to
https://github.com/csound/csound/issues Discussions of bugs and features can
be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here



--
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here



--
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Zak Clear problem

hlolli
A question (which I will find out either way), can you use chnmix without worrying if a given channel exists or not?

2017-03-17 21:33 GMT+01:00 Oeyvind Brandtsegg <[hidden email]>:
Ah, good. 
It is my preferred methods for transporting audio between instruments,
and I find it very convenient that I don't have to declare channels, just start using them (either write or read) and it will be created if it does not already exist).

Skål indeed!

2017-03-17 13:28 GMT-07:00 Hlöðver Sigurðsson <[hidden email]>:
No specific reason, didn't think of chn for anything else than export/import of data between api/csound.

Thanks for pointing that out Oeyvind,
Skål!

2017-03-17 21:17 GMT+01:00 Oeyvind Brandtsegg <[hidden email]>:
Hi Hlöðver,
any reason why you would not rather use chn than zak?
It seems zak is not so actively used anymore.
Oeyvind

2017-03-17 12:53 GMT-07:00 Hlöðver Sigurðsson <[hidden email]>:
Happened few other times as well, one was just when I was using the csound-api compiling sample tables(via CompileOrc), wasn't playing any sound, but the performance had still started. I think this is more connected to the fact Im using nodejs csound-api. So before I should wolf wolf, I should have a more solid understanding what's causing this. All I worry is that it would happen during music performance so I thought I'd ask if someone else had encountered this.

2017-03-17 17:59 GMT+01:00 jpff <[hidden email]>:
Ay cane of seeing the actual orc?  The ode is clear and simple -- that message only happens if (first < 0) || (last < 0)


On Fri, 17 Mar 2017, Hlöðver Sigurðsson wrote:

So I was playing some samples with loscil and without getting any nan, zacl
decided to die on me (csound continues to run but procuded no sound). It's bit
important that this opcode is stable, otherwise I can just change to ga_
variables.

 PERF ERROR in instr 10000: zacl first or last < 0. Not clearing.
zacl 0 4
   note aborted

Im running on MacOsX

--Csound version 6.08 (double samples) Nov 23 2016 

[commit: a1159a1e12a1095c4607f7162c44b196f5143959]

libsndfile-1.0.25


(as I post this I notice that I may want to try newer version).

Csound mailing list [hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to
https://github.com/csound/csound/issues Discussions of bugs and features can
be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here



--
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here



--
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Zak Clear problem

Oeyvind Brandtsegg-3
I think so,
and the manual says "Implies declaring the channel with imode=2", so yes, go for it :-) 

2017-03-17 13:39 GMT-07:00 Hlöðver Sigurðsson <[hidden email]>:
A question (which I will find out either way), can you use chnmix without worrying if a given channel exists or not?

2017-03-17 21:33 GMT+01:00 Oeyvind Brandtsegg <[hidden email]>:
Ah, good. 
It is my preferred methods for transporting audio between instruments,
and I find it very convenient that I don't have to declare channels, just start using them (either write or read) and it will be created if it does not already exist).

Skål indeed!

2017-03-17 13:28 GMT-07:00 Hlöðver Sigurðsson <[hidden email]>:
No specific reason, didn't think of chn for anything else than export/import of data between api/csound.

Thanks for pointing that out Oeyvind,
Skål!

2017-03-17 21:17 GMT+01:00 Oeyvind Brandtsegg <[hidden email]>:
Hi Hlöðver,
any reason why you would not rather use chn than zak?
It seems zak is not so actively used anymore.
Oeyvind

2017-03-17 12:53 GMT-07:00 Hlöðver Sigurðsson <[hidden email]>:
Happened few other times as well, one was just when I was using the csound-api compiling sample tables(via CompileOrc), wasn't playing any sound, but the performance had still started. I think this is more connected to the fact Im using nodejs csound-api. So before I should wolf wolf, I should have a more solid understanding what's causing this. All I worry is that it would happen during music performance so I thought I'd ask if someone else had encountered this.

2017-03-17 17:59 GMT+01:00 jpff <[hidden email]>:
Ay cane of seeing the actual orc?  The ode is clear and simple -- that message only happens if (first < 0) || (last < 0)


On Fri, 17 Mar 2017, Hlöðver Sigurðsson wrote:

So I was playing some samples with loscil and without getting any nan, zacl
decided to die on me (csound continues to run but procuded no sound). It's bit
important that this opcode is stable, otherwise I can just change to ga_
variables.

 PERF ERROR in instr 10000: zacl first or last < 0. Not clearing.
zacl 0 4
   note aborted

Im running on MacOsX

--Csound version 6.08 (double samples) Nov 23 2016 

[commit: a1159a1e12a1095c4607f7162c44b196f5143959]

libsndfile-1.0.25


(as I post this I notice that I may want to try newer version).

Csound mailing list [hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to
https://github.com/csound/csound/issues Discussions of bugs and features can
be posted here


Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
       https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here



--
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here



--
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here



--
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Loading...