Quantcast

[Csnd] Syncgrain FTgen Error

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Csnd] Syncgrain FTgen Error

bubget
Hi all, happy sunday...

So, the included syncgrain example comes with an audiofile browser. I have attempted to modify the code so as to eliminate the browser in order to key in the audio file manually(ie.in the code directly).

I am using the code in pure data and the browser function is not compatible.

my efforts have yielded this error

I have included the .csd file

soundin cannot open ClassGuit.wav

ftable 102: Failed to open file

f102 0.00 0.00 1.00 "ClassGuit.wav" ...

INIT ERROR in instr 0: ftgen error

giFile ftgen.iS 0 0 0 1 "ClassGuit.wav" 0 0 0

ftable 102:

ftable 103:

header init errors



thanks in advance!!






Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

syncgrainedit.csd (56K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Syncgrain FTgen Error

bubget
Another option could be, if maybe Iain or some other kindred soul, could refer me to the versions of syncgrain and fog before their respective browsers were added.....that may indeed be the simplest course of action.

On 2 April 2017 at 15:04, T Lopez <[hidden email]> wrote:
Hi all, happy sunday...

So, the included syncgrain example comes with an audiofile browser. I have attempted to modify the code so as to eliminate the browser in order to key in the audio file manually(ie.in the code directly).

I am using the code in pure data and the browser function is not compatible.

my efforts have yielded this error

I have included the .csd file

soundin cannot open ClassGuit.wav

ftable 102: Failed to open file

f102 0.00 0.00 1.00 "ClassGuit.wav" ...

INIT ERROR in instr 0: ftgen error

giFile ftgen.iS 0 0 0 1 "ClassGuit.wav" 0 0 0

ftable 102:

ftable 103:

header init errors



thanks in advance!!







Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Syncgrain FTgen Error

jpff
In reply to this post by bubget
Where did you put the file?  How are you running Csound?  The message says. It is not in the current directory nor the sound file directory.

Sent from TypeApp
On 2 Apr 2017, at 14:05, T Lopez <[hidden email]> wrote:
Hi all, happy sunday...

So, the included syncgrain example comes with an audiofile browser. I have attempted to modify the code so as to eliminate the browser in order to key in the audio file manually(ie.in the code directly).

I am using the code in pure data and the browser function is not compatible.

my efforts have yielded this error

I have included the .csd file

soundin cannot open ClassGuit.wav

ftable 102: Failed to open file

f102 0.00 0.00 1.00 "ClassGuit.wav" ...

INIT ERROR in instr 0: ftgen error

giFile ftgen.iS 0 0 0 1 "ClassGuit.wav" 0 0 0

ftable 102:

ftable 103:

header init errors



thanks in advance!!






Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Syncgrain FTgen Error

bubget

The file is running in examples/McGurdy Collection

And I'm using CsoundQT 0.91

Thx for taking the time to check it out!

On 2 Apr 2017 15:56, "John ff" <[hidden email]> wrote:
Where did you put the file?  How are you running Csound?  The message says. It is not in the current directory nor the sound file directory.

Sent from TypeApp
On 2 Apr 2017, at 14:05, T Lopez <[hidden email]> wrote:
Hi all, happy sunday...

So, the included syncgrain example comes with an audiofile browser. I have attempted to modify the code so as to eliminate the browser in order to key in the audio file manually(ie.in the code directly).

I am using the code in pure data and the browser function is not compatible.

my efforts have yielded this error

I have included the .csd file

soundin cannot open ClassGuit.wav

ftable 102: Failed to open file

f102 0.00 0.00 1.00 "ClassGuit.wav" ...

INIT ERROR in instr 0: ftgen error

giFile ftgen.iS 0 0 0 1 "ClassGuit.wav" 0 0 0

ftable 102:

ftable 103:

header init errors



thanks in advance!!






Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Syncgrain FTgen Error

Tarmo Johannes-3
In reply to this post by bubget
Hi,

Have a look at the CsOption

--env:SSDIR+=../

This tells Csound that the sound files should be one dierectory higher than
the csd. If you just remove this line and put your wav and csd into the same
folder, it should work.

or if you want to keep the soundfiles somewhere else, then point --env:SSDIR+=
to the folder where they are.

tarmo

On pühapäev, 2. aprill 2017 15:04.36 EEST you wrote:

> Hi all, happy sunday...
>
> So, the included syncgrain example comes with an audiofile browser. I have
> attempted to modify the code so as to eliminate the browser in order to key
> in the audio file manually(ie.in the code directly).
>
> I am using the code in pure data and the browser function is not compatible.
>
> my efforts have yielded this error
>
> I have included the .csd file
>
> soundin cannot open ClassGuit.wav
>
> ftable 102: Failed to open file
>
> f102 0.00 0.00 1.00 "ClassGuit.wav" ...
>
> INIT ERROR in instr 0: ftgen error
>
> giFile ftgen.iS 0 0 0 1 "ClassGuit.wav" 0 0 0
>
> ftable 102:
>
> ftable 103:
>
> header init errors
>
>
>
> thanks in advance!!
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>         https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Csnd] Syncgrain FTgen Error

bubget

Thanks so much! That seems to have done the trick!!

On 2 Apr 2017 16:50, "Tarmo Johannes" <[hidden email]> wrote:
Hi,

Have a look at the CsOption

--env:SSDIR+=../

This tells Csound that the sound files should be one dierectory higher than
the csd. If you just remove this line and put your wav and csd into the same
folder, it should work.

or if you want to keep the soundfiles somewhere else, then point --env:SSDIR+=
to the folder where they are.

tarmo

On pühapäev, 2. aprill 2017 15:04.36 EEST you wrote:
> Hi all, happy sunday...
>
> So, the included syncgrain example comes with an audiofile browser. I have
> attempted to modify the code so as to eliminate the browser in order to key
> in the audio file manually(ie.in the code directly).
>
> I am using the code in pure data and the browser function is not compatible.
>
> my efforts have yielded this error
>
> I have included the .csd file
>
> soundin cannot open ClassGuit.wav
>
> ftable 102: Failed to open file
>
> f102 0.00 0.00 1.00 "ClassGuit.wav" ...
>
> INIT ERROR in instr 0: ftgen error
>
> giFile ftgen.iS 0 0 0 1 "ClassGuit.wav" 0 0 0
>
> ftable 102:
>
> ftable 103:
>
> header init errors
>
>
>
> thanks in advance!!
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>         https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Loading...