[Csnd] Some problems with RunloopSound

classic Classic list List threaded Threaded
20 messages Options
Reply | Threaded
Open this post in threaded view
|

[Csnd] Some problems with RunloopSound

Enrico Francioni-2
Hello everyone!
I ask some help to solve some problems with RunloopSound.

In particular, I CAN NOT:
- import and play audio files;
- import the signal from the microphone (for example with "in") and play it on output.

Thanks for every suggestion,
Enrico

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

jpff
Can you be more explicit?  In what way can you not import and play audio files, or from the microphone?  Is something failing or are you asking about syntax?

⁣Sent from TypeApp ​

On Jul 4, 2018, 09:36, at 09:36, Enrico Francioni <[hidden email]> wrote:

>Hello everyone!
>I ask some help to solve some problems with RunloopSound.
>
>In particular, I CAN NOT:
>- import and play audio files;
>- import the signal from the microphone (for example with "in") and
>play it on output.
>
>Thanks for every suggestion,
>Enrico
>
>Csound mailing list
>[hidden email]
>https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>Send bugs reports to
>        https://github.com/csound/csound/issues
>Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

genell
RunloopCsound uses a sandbox on the iPhone to handle files. I have successfully imported midi files from Dropbox into the sandbox and had them rendered using the -F flag in the csoptions section of the csd.
I have not tried audio file playback though.

Can you give an example of what you want to do?

Regards,
Anders

> 4 juli 2018 kl. 14:25 skrev John ff <[hidden email]>:
>
> Can you be more explicit?  In what way can you not import and play audio files, or from the microphone?  Is something failing or are you asking about syntax?
>
> ⁣Sent from TypeApp ​
>
>> On Jul 4, 2018, 09:36, at 09:36, Enrico Francioni <[hidden email]> wrote:
>> Hello everyone!
>> I ask some help to solve some problems with RunloopSound.
>>
>> In particular, I CAN NOT:
>> - import and play audio files;
>> - import the signal from the microphone (for example with "in") and
>> play it on output.
>>
>> Thanks for every suggestion,
>> Enrico
>>
>> Csound mailing list
>> [hidden email]
>> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>> Send bugs reports to
>>       https://github.com/csound/csound/issues
>> Discussions of bugs and features can be posted here
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>        https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

Enrico Francioni-2
In reply to this post by Enrico Francioni-2
…very simple:
- in the first case the algorithm closes and I have an error;
- in the second case the microphone signal does not go to the output ...

FIRST CASE:
<CsoundSynthesizer>
<CsInstruments>
nchnls = 1
instr 1
asig diskin “test.aiff”
out(asig)
endin
</CsInstruments>
<CsScore>
i 1 0 5
e
</CsScore>
</CsoundSynthesizer>

***

SECOND CASE:
<CsoundSynthesizer>
<CsInstruments>
nchnls = 1
instr 1
asig in
out(asig)
endin
</CsInstruments>
<CsScore>
i 1 0 5
e
</CsScore>
</CsoundSynthesizer>

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

jpff
Case 1:  The error message might give a clue but pmostlikely it isnot
findingthe audio fie.  Tis couldbe because of paths or environment
ariables of simolar.  Depends a littl on te platfor, but I only know about
Linux so may not be much help.

Case 2:  I cannot see anywhere where the micropone is associated with the
in opcode.  I cud expect a "-i adc" option in the csd or the calling
scheme.


On Wed, 4 Jul 2018, Enrico Francioni wrote:

> ?very simple:
> - in the first case the algorithm closes and I have an error;
> - in the second case the microphone signal does not go to the output ...
>
> FIRST CASE:
> <CsoundSynthesizer>
> <CsInstruments>
> nchnls = 1
> instr 1
> asig diskin ?test.aiff?
> out(asig)
> endin
> </CsInstruments>
> <CsScore>
> i 1 0 5
> e
> </CsScore>
> </CsoundSynthesizer>
>
> ***
>
> SECOND CASE:
> <CsoundSynthesizer>
> <CsInstruments>
> nchnls = 1
> instr 1
> asig in
> out(asig)
> endin
> </CsInstruments>
> <CsScore>
> i 1 0 5
> e
> </CsScore>
> </CsoundSynthesizer>
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>        https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here
>

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

genell
It does indeed seem like audio input does not work. Perhaps the author could comment?

Regards,
Anders

> 4 juli 2018 kl. 18:29 skrev jpff <[hidden email]>:
>
> Case 1:  The error message might give a clue but pmostlikely it isnot findingthe audio fie.  Tis couldbe because of paths or environment ariables of simolar.  Depends a littl on te platfor, but I only know about Linux so may not be much help.
>
> Case 2:  I cannot see anywhere where the micropone is associated with the in opcode.  I cud expect a "-i adc" option in the csd or the calling scheme.
>
>
>> On Wed, 4 Jul 2018, Enrico Francioni wrote:
>>
>> ?very simple:
>> - in the first case the algorithm closes and I have an error;
>> - in the second case the microphone signal does not go to the output ...
>>
>> FIRST CASE:
>> <CsoundSynthesizer>
>> <CsInstruments>
>> nchnls = 1
>> instr 1
>> asig diskin ?test.aiff?
>> out(asig)
>> endin
>> </CsInstruments>
>> <CsScore>
>> i 1 0 5
>> e
>> </CsScore>
>> </CsoundSynthesizer>
>>
>> ***
>>
>> SECOND CASE:
>> <CsoundSynthesizer>
>> <CsInstruments>
>> nchnls = 1
>> instr 1
>> asig in
>> out(asig)
>> endin
>> </CsInstruments>
>> <CsScore>
>> i 1 0 5
>> e
>> </CsScore>
>> </CsoundSynthesizer>
>>
>> Csound mailing list
>> [hidden email]
>> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>> Send bugs reports to
>>       https://github.com/csound/csound/issues
>> Discussions of bugs and features can be posted here
>>
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>       https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

Enrico Francioni-2
In reply to this post by Enrico Francioni-2
error messages:


FIRST CASE:

UnifiedCSD: /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd
STARTING FILE
Creating options
Creating orchestra
Creating score

error: syntax error, unexpected T_IDENT, expecting NEWLINE or ',' (token "aiff") from file /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd (1)
 line 10:
>>>asig diskin “test.aiff <<<
Parsing failed due to invalid input!
Stopping on parser failure
cannot compile orchestra

***

SECOND CASE:

UnifiedCSD: /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/in.csd
STARTING FILE
Creating options
Creating orchestra
Creating score
Elapsed time at end of orchestra compile: real: 0.007s, CPU: 0.011s
sorting score ...
 ... done
Elapsed time at end of score sort: real: 0.007s, CPU: 0.011s
--Csound version 6.07 (float samples) May 16 2016
graphics suppressed, ascii substituted
0dBFS level = 32768.0
orch now loaded
audio buffered in 1024 sample-frame blocks
SECTION 1:
new alloc for instr 1:
B 0.000 .. 5.000 T 5.000 TT 5.000 M: 0.0
Score finished in csoundPerformKsmps().
inactive allocs returned to freespace
end of score. overall amps: 0.0
    overall samples out of range: 0
0 errors in performance
Elapsed time at end of performance: real: 42.570s, CPU: 0.856s

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

Dave Seidel
The first case looks like it's invalid because the name or the soundfile begins with a comma (","), and there's a missing required second parameter (kpitch).

On Thu, Jul 5, 2018 at 8:11 AM Enrico Francioni <[hidden email]> wrote:
error messages:


FIRST CASE:

UnifiedCSD: /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd
STARTING FILE
Creating options
Creating orchestra
Creating score

error: syntax error, unexpected T_IDENT, expecting NEWLINE or ',' (token "aiff") from file /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd (1)
 line 10:
>>>asig diskin “test.aiff <<<
Parsing failed due to invalid input!
Stopping on parser failure
cannot compile orchestra

***

SECOND CASE:

UnifiedCSD: /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/in.csd
STARTING FILE
Creating options
Creating orchestra
Creating score
Elapsed time at end of orchestra compile: real: 0.007s, CPU: 0.011s
sorting score ...
 ... done
Elapsed time at end of score sort: real: 0.007s, CPU: 0.011s
--Csound version 6.07 (float samples) May 16 2016
graphics suppressed, ascii substituted
0dBFS level = 32768.0
orch now loaded
audio buffered in 1024 sample-frame blocks
SECTION 1:
new alloc for instr 1:
B 0.000 .. 5.000 T 5.000 TT 5.000 M: 0.0
Score finished in csoundPerformKsmps().
inactive allocs returned to freespace
end of score. overall amps: 0.0
    overall samples out of range: 0
0 errors in performance
Elapsed time at end of performance: real: 42.570s, CPU: 0.856s

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here


--
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

Dave Seidel
sorry, "name OF the soundfile..."

On Thu, Jul 5, 2018 at 8:33 AM Dave Seidel <[hidden email]> wrote:
The first case looks like it's invalid because the name or the soundfile begins with a comma (","), and there's a missing required second parameter (kpitch).

On Thu, Jul 5, 2018 at 8:11 AM Enrico Francioni <[hidden email]> wrote:
error messages:


FIRST CASE:

UnifiedCSD: /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd
STARTING FILE
Creating options
Creating orchestra
Creating score

error: syntax error, unexpected T_IDENT, expecting NEWLINE or ',' (token "aiff") from file /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd (1)
 line 10:
>>>asig diskin “test.aiff <<<
Parsing failed due to invalid input!
Stopping on parser failure
cannot compile orchestra

***

SECOND CASE:

UnifiedCSD: /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/in.csd
STARTING FILE
Creating options
Creating orchestra
Creating score
Elapsed time at end of orchestra compile: real: 0.007s, CPU: 0.011s
sorting score ...
 ... done
Elapsed time at end of score sort: real: 0.007s, CPU: 0.011s
--Csound version 6.07 (float samples) May 16 2016
graphics suppressed, ascii substituted
0dBFS level = 32768.0
orch now loaded
audio buffered in 1024 sample-frame blocks
SECTION 1:
new alloc for instr 1:
B 0.000 .. 5.000 T 5.000 TT 5.000 M: 0.0
Score finished in csoundPerformKsmps().
inactive allocs returned to freespace
end of score. overall amps: 0.0
    overall samples out of range: 0
0 errors in performance
Elapsed time at end of performance: real: 42.570s, CPU: 0.856s

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here


--


--
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

jpff
In reply to this post by Enrico Francioni-2
Just a small thought.  How did you create the audio_in.csdfile?  It could be that you used a word processor which adds non ASCII characters.  The message looks clear to me that the string is not as you think.

⁣Sent from TypeApp ​

On Jul 5, 2018, 13:11, at 13:11, Enrico Francioni <[hidden email]> wrote:

>error messages:
>
>
>FIRST CASE:
>
>UnifiedCSD:
>/private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd
>STARTING FILE
>Creating options
>Creating orchestra
>Creating score
>
>error: syntax error, unexpected T_IDENT, expecting NEWLINE or ','
>(token "aiff") from file
>/private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd
>(1)
> line 10:
>>>>asig diskin “test.aiff <<<
>Parsing failed due to invalid input!
>Stopping on parser failure
>cannot compile orchestra
>
>***
>
>SECOND CASE:
>
>UnifiedCSD:
>/private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/in.csd
>STARTING FILE
>Creating options
>Creating orchestra
>Creating score
>Elapsed time at end of orchestra compile: real: 0.007s, CPU: 0.011s
>sorting score ...
> ... done
>Elapsed time at end of score sort: real: 0.007s, CPU: 0.011s
>--Csound version 6.07 (float samples) May 16 2016
>graphics suppressed, ascii substituted
>0dBFS level = 32768.0
>orch now loaded
>audio buffered in 1024 sample-frame blocks
>SECTION 1:
>new alloc for instr 1:
>B 0.000 .. 5.000 T 5.000 TT 5.000 M: 0.0
>Score finished in csoundPerformKsmps().
>inactive allocs returned to freespace
>end of score. overall amps: 0.0
>    overall samples out of range: 0
>0 errors in performance
>Elapsed time at end of performance: real: 42.570s, CPU: 0.856s
>
>Csound mailing list
>[hidden email]
>https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
>Send bugs reports to
>        https://github.com/csound/csound/issues
>Discussions of bugs and features can be posted here

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

jpff
In reply to this post by Dave Seidel
On Thu, 5 Jul 2018, Dave Seidel wrote:

> sorry, "name OF the soundfile..."
>
> On Thu, Jul 5, 2018 at 8:33 AM Dave Seidel <[hidden email]> wrote:
>       The first case looks like it's invalid because the name or the
>       soundfile begins with a comma (","), and there's a missing
>       required second parameter (kpitch).

The kpitch paramater is optional, defaulting to 1, so it is the unexpected
comma.

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

genell
In reply to this post by genell
Here’s an answer from the author about live audio input.

Regards,
Anders

> 5 juli 2018 kl. 15:28 skrev Vieira Damiani, Luis F <[hidden email]>:
>
> Hey Anders,
>
> Audio input only works in the context of Inter-App Audio. When connected to a host, like GarageBand, RunloopSound will display an overlay of several buttons, including one that turns on live audio input through the host.
>
> Best,
>
> Luis
>
>> On Jul 5, 2018, at 4:05 AM, Anders Genell <[hidden email]> wrote:
>>
>> It does indeed seem like audio input does not work. Perhaps the author could comment?
>>
>> Regards,
>> Anders
>>
>>> 4 juli 2018 kl. 18:29 skrev jpff <[hidden email]>:
>>>
>>> Case 1:  The error message might give a clue but pmostlikely it isnot findingthe audio fie.  Tis couldbe because of paths or environment ariables of simolar.  Depends a littl on te platfor, but I only know about Linux so may not be much help.
>>>
>>> Case 2:  I cannot see anywhere where the micropone is associated with the in opcode.  I cud expect a "-i adc" option in the csd or the calling scheme.
>>>
>>>
>>>> On Wed, 4 Jul 2018, Enrico Francioni wrote:
>>>>
>>>> ?very simple:
>>>> - in the first case the algorithm closes and I have an error;
>>>> - in the second case the microphone signal does not go to the output ...
>>>>
>>>> FIRST CASE:
>>>> <CsoundSynthesizer>
>>>> <CsInstruments>
>>>> nchnls = 1
>>>> instr 1
>>>> asig diskin ?test.aiff?
>>>> out(asig)
>>>> endin
>>>> </CsInstruments>
>>>> <CsScore>
>>>> i 1 0 5
>>>> e
>>>> </CsScore>
>>>> </CsoundSynthesizer>
>>>>
>>>> ***
>>>>
>>>> SECOND CASE:
>>>> <CsoundSynthesizer>
>>>> <CsInstruments>
>>>> nchnls = 1
>>>> instr 1
>>>> asig in
>>>> out(asig)
>>>> endin
>>>> </CsInstruments>
>>>> <CsScore>
>>>> i 1 0 5
>>>> e
>>>> </CsScore>
>>>> </CsoundSynthesizer>
>>>>
>>>> Csound mailing list
>>>> [hidden email]
>>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__listserv.heanet.ie_cgi-2Dbin_wa-3FA0-3DCSOUND&d=DwIFAg&c=pZJPUDQ3SB9JplYbifm4nt2lEVG5pWx2KikqINpWlZM&r=YihhonIjnlIN6Wuo58LaXg&m=-szFKCOrRLNYbZvMBzBZnX6fZAgMDGXSLzbyb-O46gQ&s=3y9SF8TaP9cGwWHBB0w4xolSJDwuX84JgUF2AaQVKKg&e=
>>>> Send bugs reports to
>>>>     https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_csound_csound_issues&d=DwIFAg&c=pZJPUDQ3SB9JplYbifm4nt2lEVG5pWx2KikqINpWlZM&r=YihhonIjnlIN6Wuo58LaXg&m=-szFKCOrRLNYbZvMBzBZnX6fZAgMDGXSLzbyb-O46gQ&s=ouvWd-uEOS-PvHgHCtlroK_fxqsbCui09aoQfXDCnVI&e=
>>>> Discussions of bugs and features can be posted here
>>>>
>>>
>>> Csound mailing list
>>> [hidden email]
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__listserv.heanet.ie_cgi-2Dbin_wa-3FA0-3DCSOUND&d=DwIFAg&c=pZJPUDQ3SB9JplYbifm4nt2lEVG5pWx2KikqINpWlZM&r=YihhonIjnlIN6Wuo58LaXg&m=-szFKCOrRLNYbZvMBzBZnX6fZAgMDGXSLzbyb-O46gQ&s=3y9SF8TaP9cGwWHBB0w4xolSJDwuX84JgUF2AaQVKKg&e=
>>> Send bugs reports to
>>>     https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_csound_csound_issues&d=DwIFAg&c=pZJPUDQ3SB9JplYbifm4nt2lEVG5pWx2KikqINpWlZM&r=YihhonIjnlIN6Wuo58LaXg&m=-szFKCOrRLNYbZvMBzBZnX6fZAgMDGXSLzbyb-O46gQ&s=ouvWd-uEOS-PvHgHCtlroK_fxqsbCui09aoQfXDCnVI&e=
>>> Discussions of bugs and features can be posted here
>

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

Enrico Francioni-2
In reply to this post by Enrico Francioni-2
John,

the csd "audio_in.csd" was created with the editor that is in RunloopSound…

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

jpff
OK it was an idea.  One could hit it with a heavy cluestick; if you can
captue outout try running with an option of -v
<CsOptions>
-v
</CsOptions>

That should show what is ctually happening.  It will prodce quite a lot of
tracing.

Failing that could you attach (ie not mail) your csd file so it can be
checked?  Possibly just to me ....

==John

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

jpff
In reply to this post by Enrico Francioni-2
Just looked at your input inthe listarchive. The opening doubke quoteis
not ascii " but a curved version; think closing is wrong too.  You need

asig diskin "test.aiff"

and not wat you have

On Fri, 6 Jul 2018, Enrico Francioni wrote:

> John,
>
> the csd "audio_in.csd" was created with the editor that is in RunloopSound?
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>        https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here
>

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

Enrico Francioni-2
In reply to this post by Enrico Francioni-2
Hi John!

I applied the advice you gave me above;
below copy:
- the code of the csd "audio_in.csd";
- the error message (after putting -v between the options).

Instead for the "in.csd" file (to export the microphone signal) - after Luis's suggestion (posted by "genell" that I thank) -
I assume that it is necessary to buy Inter-App-Audio (€ 5.49) to be able to host the host eg GarageBand ...

*

; "audio_in.csd" - code:

<CsoundSynthesizer>
<CsOptions>
-i adc
-v
</CsOptions>
<CsInstruments>

nchnls = 1

instr 1
asig diskin “test.aiff”
out(asig)
endin
</CsInstruments>
<CsScore>
i 1 0 5
e
</CsScore>
</CsoundSynthesizer>

§

; error message:

UnifiedCSD: /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd
STARTING FILE
Creating options
Creating orchestra
Creating score
Calling preprocess on >>
nchnls = 1

instr 1
asig diskin “test.aiff”
out(asig)
endin

#exit
<<

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 8

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 8

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 9

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 11

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 11

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 11

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 11


error: syntax error, unexpected T_IDENT, expecting NEWLINE or ',' (token "aiff") from file /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd (1)
 line 11:
>>>asig diskin “test.aiff <<<
Semantic Analysis
(0x1c0682f90)Instr: 1
  read(0x1c0683030): { }
  write:(0x1c0682fe0) { }
  read_write(0x1c0683440): { }
Semantic Analysis Ends
Parsing failed due to invalid input!
Stopping on parser failure
cannot compile orchestra
end of score. overall amps: 0.0
    overall samples out of range: 0
1 errors in performance
Elapsed time at end of performance: real: 108.103s, CPU: 4.732s

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

jpff
As I said the double quoteyouhavr is not ASCII character " but I no not know what it is as somewhere in the chain it is getting modified.  That is why I asked for an attachment or an encoded copy.

You can see that in the -v output there is the sequence
,Äú
where there should be a "

You have a character coding issue. Without the real input and having no Apple kit I cannot help
Sent from Blue
On 6 Jul 2018, at 21:36, Enrico Francioni <[hidden email]> wrote:
Hi John!

I applied the advice you gave me above;
below copy:
- the code of the csd "audio_in.csd";
- the error message (after putting -v between the options).

Instead for the "in.csd" file (to export the microphone signal) - after Luis's suggestion (posted by "genell" that I thank) -
I assume that it is necessary to buy Inter-App-Audio (€ 5.49) to be able to host the host eg GarageBand ...

*

; "audio_in.csd" - code:

<CsoundSynthesizer>
<CsOptions>
-i adc
-v
</CsOptions>
<CsInstruments>

nchnls = 1

instr 1
asig diskin “test.aiff”
out(asig)
endin
</CsInstruments>
<CsScore>
i 1 0 5
e
</CsScore>
</CsoundSynthesizer>

§

; error message:

UnifiedCSD: /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd
STARTING FILE
Creating options
Creating orchestra
Creating score
Calling preprocess on >>
nchnls = 1

instr 1
asig diskin “test.aiff”
out(asig)
endin

#exit
<<

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 8

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 8

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 9

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 11

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 11

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 11

/Users/stevenyi/work/csound/csound6/Engine/csound_orc_semantics.c(1970) line = 11


error: syntax error, unexpected T_IDENT, expecting NEWLINE or ',' (token "aiff") from file /private/var/mobile/Containers/Data/Application/B83C75B7-BB43-4FF2-9079-9EB078432189/Documents/csd/audio_in.csd (1)
line 11:
asig diskin “test.aiff <<<
Semantic Analysis
(0x1c0682f90)Instr: 1
read(0x1c0683030): { }
write:(0x1c0682fe0) { }
read_write(0x1c0683440): { }
Semantic Analysis Ends
Parsing failed due to invalid input!
Stopping on parser failure
cannot compile orchestra
end of score. overall amps: 0.0
overall samples out of range: 0
1 errors in performance
Elapsed time at end of performance: real: 108.103s, CPU: 4.732s

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

Enrico Francioni-2
In reply to this post by Enrico Francioni-2
John,
I do not understand what you would like to know exactly,
but if it can help you understand the problem even better:
the "RunloopSound" app was installed on iPhone SE with iOS 11.4

*

I would rather like the author [Luis] to intervene, in some way, also on this forum.
I also tried to contact him privately ... but in vain.

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

Enrico Francioni-2
In reply to this post by Enrico Francioni-2
FIRST CASE:

Following John's directions,
I finally solved the problem and now the CSD works.
It was enough to "deform" the wrong character ["] with TextEdit, in my MacBookPro, and then paste it into the csd code.

Then looking in the Settings of the Keyboard of the iPhone was enough to disable the "Smart punctuation" to get the character ["]
already "deformed".

Now everything seems to work.

Thank you all…!

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here
Reply | Threaded
Open this post in threaded view
|

Re: [Csnd] Some problems with RunloopSound

jpff
I am pleased you worked it out
==John ff


On Sat, 7 Jul 2018, Enrico Francioni wrote:

> FIRST CASE:
>
> Following John's directions,
> I finally solved the problem and now the CSD works.
> It was enough to "deform" the wrong character ["] with TextEdit, in my MacBookPro, and then paste it into the csd code.
>
> Then looking in the Settings of the Keyboard of the iPhone was enough to disable the "Smart punctuation" to get the character ["]
> already "deformed".
>
> Now everything seems to work.
>
> Thank you all?!
>
> Csound mailing list
> [hidden email]
> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
> Send bugs reports to
>        https://github.com/csound/csound/issues
> Discussions of bugs and features can be posted here
>

Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here